Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I want to find out, which footnote is causing a warning message in my pdfoutput.

I am using Miktex 2.9, my document is from the type "scrreprt" and I make usage of the package parnotes.

I get the message: {HFootnote.9} has been referenced but does not exist, replaced by a fixed one.

I know that there are many questions and answers to this topic, but the solutions do not work out for me. I tried the following:

  • hyperref is loaded as the last package
  • yes, I use footnotes in tables, but that's what the package "parnotes" is good for, isn't it?

I can't provide a minimal example, because then I would know which footnote does cause the error. My document has a size of 250 pages and I do not have the time to check each of the footnotes if it is displayed and linked correctly (I have to finish my Masterthesis in three days).

Can someone please tell me how I can find out which footnote does cause the trouble?

Just in case that I somehow misused the parnotes-package in my tables, here is an example of one of my tables (the table and the footnote is displayed correctly):

\begin{table}[htbp]                 
    \begin{tabularx}{\textwidth}{|L{2.5cm}|X|p{11cm}|}
    \toprule
    \parnoteclear
    \textbf{Anforderung} & \textbf{P(5)} & \textbf{Bewertung}\\                 
        \midrule                    
    Preis & / & Some text\parnote{My footnote text.} which has a value of 80~\texteuro\ per month.\\        
    \bottomrule
\end{tabularx}  
\parnotes                           
\caption{My caption for this table.}
\label{tab:ModelingToolSignavio}                
\end{table}

This is the definition of the parnoteclear-command:

\usepackage{parskip}
\usepackage{tabularx}
\usepackage[roman]{parnotes}    % enables footnotes in tables

\def\parnoteclear{%
    \gdef\PN@text{}%
    \parnotereset
}

Thanks in advance for every hint, idea or advise.
Timo

share|improve this question
2  
Option verbose of package hyperref writes some infos about anchor settings, links and other stuff into the .log file that might help to find the location in the source code. –  Heiko Oberdiek Aug 13 '12 at 13:34

1 Answer 1

up vote 1 down vote accepted

Your error is produced by the following MWE:

\documentclass{article}

\usepackage{hyperref}
\begin{document}
Test\footnote{Footnote text.}.
\begin{table}[t]
  \centering
  \begin{tabular}{cc}
    First & Second\footnote{Second footnote.}
  \end{tabular}
  \caption{Caption}
  \label{tab:t}
\end{table}

\end{document}

this time with reference to {HFootnote.2}. The .2 means that is the second footnote causing the problem. Cutting and pasting your other code in does not produce the error your report from the table with a \parnote. So try to track down direct uses of the \footnote command in your document.

hyperref has all sorts of issues with footnotes. See the answers to the question Clickable Table Footnote, for discussion, why not to do this, and workarounds.

share|improve this answer
    
Thank you for this hint. I checked the mentioned file, but there was only one footnote. So I checked my glossary-entries and I found a reference to another glossary-entry. For the reason, that I mention my glossary entries on first appearance in the footnote-section, this has caused a "footnote in the footnote". Thank you very much for your help! –  Timo Paschke Aug 13 '12 at 11:50

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.