Sign up ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I am trying to input Harvard style bibliography in my master thesis but I cant do it. In the pdf file, I see the references but either they do not have the names at all, but they have the title of the book the publisher and the year or they are not placed in the appropriate position or either the url that I have inserted is not recognised. I am using a different file (Dissertation.bib):

ALTauthor = {Breuer, L. and Baum, D.},
ALTeditor = {•},
title = {An Introduction to Queueing Theory and Matrix-Analytic Methods},
chapter = {6},
publisher = {Springer},
year = {2005},
OPTkey = {•},
OPTvolume = {•},
OPTnumber = {•},
OPTseries = {•},
OPTtype = {•},
OPTaddress = {•},
OPTedition = {•},
OPTmonth = {•},
OPTpages = {•},
OPTnote = {•},
OPTannote = {•}

[1] An Introduction to Queueing Theory and Matrix-Analytic Methods, chap- ter 6. Springer, 2005.

In the main program of my dissertation I have:


Am I doing something wrong?

share|improve this question
Welcome to! A tip: If you indent lines by 4 spaces, they'll be marked as a code sample. You can also highlight the code and click the "code" button (with "{}" on it). – Joseph Wright Aug 13 '12 at 12:28
Have a look to the question how-do-i-use-the-harvard-citation-style. – Kurt Aug 13 '12 at 12:47
In addition to @Kurt's comment you may want to change ALTauthor and ALTeditor to author and editor, respectively. – hakaze Aug 13 '12 at 12:55
Did you try changing ALTauthor into author? – egreg Aug 13 '12 at 12:57
yes,when I change ALTauthor to author it doesn't compile!When I inserted the package that Kurt said I had errors too.\usepackage{amsmath} \usepackage{amsfonts} \usepackage{amssymb} \usepackage{graphicx} \usepackage{setspace} \usepackage{amsthm} \usepackage[english]{babel} \usepackage[autostyle]{csquotes} \usepackage{mathtools} this is what I am using – Vangelis Aug 13 '12 at 13:06

2 Answers 2

Your bibliography file entry should be simply

  author = {Breuer, L. and Baum, D.},
  title = {An Introduction to Queueing Theory and Matrix-Analytic Methods},
  chapter = 6,
  publisher = {Springer},
  year = 2005,

All prefixes ALT and OPT should be removed. They are inserted by bibtex-mode in emacs and can be removed in one fell swoop (in emacs) by C-c C-c to 'clean' the bibtex entry. Also, in your posted code, the fields such as key should not have a dot as argument; it is best to remove these lines.

For @InBook you should either have an author or an editor field, but not both; this is what the ALT prefixes are trying to tell you. A minimal plain file making this work is





Now modify this following the instructions of How do I use the Harvard citation style? as suggested by Kurt to invoke a Harvard like style.

share|improve this answer
I don't follow why one can't have both an author and an editor field in an entry of type @inbook. After all, the author of the chapter in question might be different from the editor of the entire book. That said, I think that the OP really ought to be using the entry type @book instead of @inbook for the entry at hand. – Mico Aug 13 '12 at 15:16
First of all thanks guys!Now,the problem with the names is corrected,everything looks good,but I can't insert the harvard style,I inserted the package,I changed the style,but I have compile errors,Why?? Last thing, I wanted to insert notes from the internet but the link doesn't appear in the pdf,I have inserted the url package but I can't see the link in the paper,Thank you very very much – Vangelis Aug 13 '12 at 15:28
The "ALT" and "OPT" fields do no harm, as BibTeX ignores them. – egreg Aug 13 '12 at 20:10
@egreg Yes BibTex ignores them, so if they are empty they harmless. But if you want to provide e.g. the author info, then you must have author and not ALTauthor – Andrew Swann Aug 14 '12 at 9:39
@Mico The plain style will not print the editor field if the author field is present. @InBook here is appropriate as it is a single chapter, not the whole book. @InCollection is available for the situation you are thinking of. – Andrew Swann Aug 14 '12 at 9:45

Not really an answer but too long for a coment. Just use the following MWE to show us your problem. It includes a bib file and loads package natbib.

\RequirePackage{filecontents}     % creates bib file
  author      = {{S}charrer, {M}artin},
  year        = {2012},
  title       = {The mwe-Package},
  edition     = {0.3},
  language    = {english},
  lastchecked = {2012-07-12},
  url         = {},
  note        = {macros/latex/contrib/mwe}
  author = {Breuer, L. and Baum, D.},
  title = {An Introduction to Queueing Theory and Matrix-Analytic Methods},
  publisher = {Springer},
  year = 2005,
  author = {Virtamo, J.}, 
  title  = {Queueing Theory / Poisson process}, 
  year   = {2007}, 
  url    = {}, 


\usepackage[numbers]{natbib}  % \citep{}, \citet{}
  hidelinks  % to make links not clickable 
]{hyperref}         % url pretty printing

\section{First section}

Minimal Working Example MWE.

citations: \cite{Renewal}, \cite{Poisson}, \citep{mwe}, \citet{mwe}, \citep*{mwe}. 

\bibliographystyle{unsrtnat}  % abbrvnat plainnat
\bibliography{\jobname}       % name of your .bib file here

Package filecontents is used to keep bib file and tex code in one MWE.

share|improve this answer
Finally I can't compile the latex file when I insert the packages for harvard style,I get errors ,now I have [1] L. Breuer and D. Baum. An Introduction to Queueing Theory and Matrix- Analytic Methods, chapter 6. Springer, 2005. In harvard its the authors first then the date in brackets,what's going wrong?Thank you very much.. – Vangelis Aug 13 '12 at 17:49
Please copy my MWE, insert your changes in bib file and in tex file, update your question (use the link èdit` under your question) so we can reproduce the errors you get. Without your code and the exact error message no one can help you. – Kurt Aug 13 '12 at 17:59
Everything works fine,thank you very very much,Is there any way to remove the colours and the boxes from my main pdf,because I don't like them – Vangelis Aug 13 '12 at 18:51
In fact is there any way not to make clickable the links,and how in the bib file can I leave a line because in this reference @booklet{Poisson, author = {Virtamo, J.}, title = {Queueing Theory / Poisson process}, year = {2007}, url = {}, }the year and the url are on the same line – Vangelis Aug 13 '12 at 19:06
@vangelis: with the option hidelinks for package hyperrefthey will disapear. – Kurt Aug 13 '12 at 19:15

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.