Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I am trying to compile an existing tex-document with tex4ht. However, it seems that the tabu-package does not work together with tex4ht:

\documentclass{book}

\usepackage{tabularx}
\usepackage{tabu}

\begin{document}
Hallo
\end{document} 

Already trying to load the tabu-package gives errors:

This is pdfTeX, Version 3.1415926-2.3-1.40.12 (MiKTeX 2.9) (preloaded format=latex  2012.8.13)  13 AUG 2012 15:58
entering extended mode
**\makeatletter\def\HCode{\futurelet\HCode\HChar}\def\HChar{\ifx\HCode\def\HCod
e##1{\Link##1}\expandafter\HCode\else\expandafter\Link\fi}\def\Link#1.a.b.c.{\g
@addto@macro\@documentclasshook{\RequirePackage[#1,html]{tex4ht}}\let\HCode\doc
umentstyle\def\documentstyle{\let\documentstyle\HCode\expandafter\def\csname te
x4ht\endcsname{#1,html}\def\HCode####1{\documentstyle[tex4ht,}\@ifnextchar[{\HC
ode}{\documentstyle[tex4ht]}}}\makeatother\HCode .a.b.c.\input  minimal.tex
(C:\Users\swilke\Documents\latex\Test\Testhtml\minimal.tex
("C:\Program Files (x86)\MiKTeX 2.9\tex\latex\base\book.cls"
Document Class: book 2007/10/19 v1.4h Standard LaTeX document class
("C:\Program Files (x86)\MiKTeX 2.9\tex\latex\base\bk10.clo"
File: bk10.clo 2007/10/19 v1.4h Standard LaTeX file (size option)
)
... [Lots of lines omitted]

! Argument of \g:Advance has an extra }.

Any help would be appreciated.

share|improve this question

closed as not constructive by egreg, Kurt, Qrrbrbirlbel, Martin Schröder, Werner Jan 5 '13 at 21:55

As it currently stands, this question is not a good fit for our Q&A format. We expect answers to be supported by facts, references, or expertise, but this question will likely solicit debate, arguments, polling, or extended discussion. If you feel that this question can be improved and possibly reopened, visit the help center for guidance.If this question can be reworded to fit the rules in the help center, please edit the question.

    
My feeling is that tex4ht needs adding support for the tabu environment; it must know about it and I guess it hasn't still found its way to the developers. –  egreg Oct 6 '12 at 23:38
add comment

Browse other questions tagged or ask your own question.