Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

Today I changed in my latex document for my dissertation the option to "twoside". After that I got a problem with some headseplines. Everytime when it comes to a new chapter, the first side doesnt get the headsepline for:

 \ihead{\headmark}

Unfortunately I am using

 scrartcl

for this. I havnt enough time to change it to scrbook or scrrprt... So I used twoside:

 \documentclass[a4paper, 12pt, german, headsepline, footsepline, listtotoc, bibtotoc, twoside]{scrartcl}

with

 \usepackage[headsepline,plainheadsepline]{scrpage2}
 \clearscrheadfoot
 \pagestyle{scrheadings}
 \automark[subsection]{section}
 \ohead{Title of Dissertation}
 \ihead{\headmark} %is missing every new section
 \ofoot{University}
 \ifoot{\pagemark}

How to fix that problem?

share|improve this question

migrated from stackoverflow.com Aug 13 '12 at 16:50

This question came from our site for professional and enthusiast programmers.

    
Welcome to TeX.sx! Your question was migrated here from another stackexchange site. Please register on this site, too, and make sure that both accounts are associated with each other (by using the same OpenID), otherwise you won't be able to comment on or accept answers or edit your question. –  Marco Daniel Aug 13 '12 at 16:52

2 Answers 2

I would not call the necessity to use KOMA-script classes unfortunate.

Regarding your problem, I suggest you use only scrpage2 for the declaration of the seplines (and not the global options for documentclass).

The opening pages (like for example pages starting a chapter) use the pagestyle scrplain. Changes to this pagestyle can be made via the optional parameter of the respective postion command, e.g. \ohead. After applying these changes your document can be easily upgraded to scrreprt or scrbook by adjusting \automark and using chapters.

\documentclass[paper=a4, fontsize=12pt]{scrartcl} % for scrreprt adjust automark

\usepackage[headsepline,plainheadsepline,footsepline,plainfootsepline]{scrpage2}
\clearscrheadfoot
\pagestyle{scrheadings}

% use for scrartcl
\automark[subsction]{section}
% use for scrreprt and scrbook
% \automark[section]{chapter}

% \position[scrplain]{scrheadings}
\ohead[Title of Dissertation]{Title of Dissertation}
\ihead[\headmark]{\headmark} 
\ofoot[University]{University}
\ifoot[\pagemark]{\pagemark}

\usepackage{lipsum}

\begin{document}
\tableofcontents
%\chapter{One}
\section{One}
\lipsum
\end{document}
share|improve this answer

You could use scrreprt or scrbook, if you're writing a thesis. Using scrbook really calls scrheadings+automark by default.

\headmark is missing every new section because, as said in the other answer, new chapters are set for scrplain style (I don't know why sections should even start on a new page if you're using scrartcl).

Using:

\renewcommand{\chapterpagestyle}{scrheadings}

will set chapter pages just like all others.

You could also try:

\documentclass[a4paper,12pt,headsepline=true]{scrbook}
\usepackage{scrpage2}
\usepackage[german]{babel}
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.