Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I'm using MiKTeX 2.9 and I want to specify the command line option --shell-escape. The reason for this is that I'm trying to use an eps file and I get the error

xxx-eps-converted-to.pdf' not found.

I read that this command line option can fix the problem, but where exactly do I specify it? I'm typesetting with LuaLaTeX using TeXworks as the editor.

EDIT: added editor.

share|improve this question
    
Are you running LuaLaTeX from the command line or using an editor, and if so which one? –  Joseph Wright Aug 13 '12 at 17:56
    
@JosephWright TeXworks, added it to my question. –  Mr. Roland Aug 13 '12 at 17:58
add comment

2 Answers 2

up vote 7 down vote accepted

With TeXworks, go to the main menu: Edit / Preferences, choose the Typesetting tab, choose your engine, click the Edit button, add --enable-write18 such as here:

Screenshot from TeXworks

This screenshot was originally posted by Thorsten in the LaTeX-Community forum. In the picture it's for pdfLaTeX, just edit the engine of your choice, i.e. LuaLaTeX.

Use the very same place if you would like to add --shell-escape instead. However, --shell-escape is used in TeX Live, --enable-write18 in MiKTeX.

share|improve this answer
2  
In addition: --enable-write18 is the original switch for MiKTeX, but --shell-escape works, too. –  Speravir Aug 13 '12 at 18:11
add comment

Specify the switch after invoking LuaLaTeX. As an example, lualatex --shell-escape luatex.tex. This assumes you’re invoking LuaLaTeX from a command line.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.