Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

My coauthor sent me a latex file calling for tikz. I find that LaTeX chokes on loading tikz. I am using a freshly installed texlive2012 installation (but I checked same thing happens on TeX Live 2011 an 2010).

Test file:

\documentclass[11pt,reqno]{amsart}
\usepackage{tikz}
\begin{document}
blah
\end{document}

Errors:

(/usr/local/texlive/2012/texmf-dist/tex/latex/amscls/amsart.cls
Document Class: amsart 2009/07/02 v2.20.1
(/usr/local/texlive/2012/texmf-dist/tex/latex/amsmath/amsmath.sty
For additional information on amsmath, use the `?' option.
(/usr/local/texlive/2012/texmf-dist/tex/latex/amsmath/amstext.sty
(/usr/local/texlive/2012/texmf-dist/tex/latex/amsmath/amsgen.sty))
(/usr/local/texlive/2012/texmf-dist/tex/latex/amsmath/amsbsy.sty)
(/usr/local/texlive/2012/texmf-dist/tex/latex/amsmath/amsopn.sty))
(/usr/local/texlive/2012/texmf-dist/tex/latex/amsfonts/umsa.fd)
(/usr/local/texlive/2012/texmf-dist/tex/latex/amsfonts/amsfonts.sty))
(/usr/local/texlive/2012/texmf-dist/tex/latex/pgf/frontendlayer/tikz.sty
(/Users/fgoodman/Library/texmf/tex/latex/pgf/pgf.sty
(/usr/local/texlive/2012/texmf-dist/tex/latex/graphics/graphicx.sty
(/usr/local/texlive/2012/texmf-dist/tex/latex/graphics/keyval.sty)
(/usr/local/texlive/2012/texmf-dist/tex/latex/graphics/graphics.sty
(/usr/local/texlive/2012/texmf-dist/tex/latex/graphics/trig.sty)
(/usr/local/texlive/2012/texmf-dist/tex/latex/latexconfig/graphics.cfg)
(/usr/local/texlive/2012/texmf-dist/tex/latex/pdftex-def/pdftex.def
(/usr/local/texlive/2012/texmf-dist/tex/generic/oberdiek/infwarerr.sty)
(/usr/local/texlive/2012/texmf-dist/tex/generic/oberdiek/ltxcmds.sty))))
(/usr/local/texlive/2012/texmf-dist/tex/latex/xcolor/xcolor.sty
(/usr/local/texlive/2012/texmf-dist/tex/latex/latexconfig/color.cfg)))
(/usr/local/texlive/2012/texmf-dist/tex/latex/pgf/utilities/pgffor.sty
(/usr/local/texlive/2012/texmf-dist/tex/latex/pgf/utilities/pgfrcs.sty
(/usr/local/texlive/2012/texmf-dist/tex/generic/pgf/utilities/pgfutil-common.te
x)
(/usr/local/texlive/2012/texmf-dist/tex/generic/pgf/utilities/pgfutil-latex.def
(/usr/local/texlive/2012/texmf-dist/tex/latex/ms/everyshi.sty))
(/usr/local/texlive/2012/texmf-dist/tex/generic/pgf/utilities/pgfrcs.code.tex))
 (/usr/local/texlive/2012/texmf-dist/tex/latex/pgf/utilities/pgfkeys.sty
(/usr/local/texlive/2012/texmf-dist/tex/generic/pgf/utilities/pgfkeys.code.tex
(/usr/local/texlive/2012/texmf-dist/tex/generic/pgf/utilities/pgfkeysfiltered.c
ode.tex)))
(/usr/local/texlive/2012/texmf-dist/tex/generic/pgf/utilities/pgffor.code.tex))

(/usr/local/texlive/2012/texmf-dist/tex/generic/pgf/frontendlayer/tikz/tikz.cod
e.tex
(/usr/local/texlive/2012/texmf-dist/tex/generic/pgf/libraries/pgflibraryplothan
dlers.code.tex
/usr/local/texlive/2012/texmf-dist/tex/generic/pgf/libraries/pgflibraryplothand
lers.code.tex:104: Undefined control sequence.
\pgfsetplottension ...ttension {\pgf@sys@tonumber 
                                                  \pgf@x }
l.104 \pgfsetplottension{0.5}

? 
Process aborted
share|improve this question
    
Welcome to TeX.sx! A tip: If you indent lines by 4 spaces, they'll be marked as a code sample. You can also highlight the code and click the "code" button (with "{}" on it). –  Joseph Wright Aug 14 '12 at 19:14
    
I had this problem too, once upon a time when I was using tetex. When I switched completely to texlive everything was fine, but that transition period with some locally installed packages, some tetex, and some texlive... That was a messy time. –  Jack Schmidt Aug 14 '12 at 21:50
add comment

1 Answer 1

The demo works fine for me, as I would expect. Your issue is shown by the line

(/Users/fgoodman/Library/texmf/tex/latex/pgf/pgf.sty

in the log file. You have a local copy of pgf.sty, probably an old one, which is being loaded in preference to the 'system wide' one which will be in /usr/local/texlive/2012 (or other year, as appropriate). Try moving the old file outside of ~/Library/texmf: indeed, you may have other old files there too, so check your log carefully.

share|improve this answer
    
Thanks, that was it. –  user17597 Aug 14 '12 at 19:16
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.