Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I'm trying to use the lettergothic package in LaTeX for the Letter Gothic monospaced font. According to the LaTeX Font Catalog, it would be simple to use it with

\usepackage[scaled]{ulgothic}
\usepackage[T1]{fontenc}

but, for some reason it does not work. After compiling (with pdflatex) I get this message (the last lines):

kpathsea: Running mktexpk --mfmode / --bdpi 600 --mag 1+12/600 --dpi 612 ulgb8rmktexpk: don't know how to create bitmap font for ulgb8r.
kpathsea: Appending font creation commands to missfont.log.

!pdfTeX error: pdflatex (file ulgb8r): Font ulgb8r at 612 not found
 ==> Fatal error occurred, no output PDF file produced!

LaTeX exited abnormally with code 70 at Wed Aug 15 00:46:57

I can't understand why this is happening since I have all the files installed on my system. I've installed all nonfree fonts (which Letter Gothic belongs) with

$ sudo getnonfreefonts-sys -a

and sudo updmap-sys and sudo texhash. All the files are where they were supposed to be.

I'm using Ubuntu 12.04 with texlive and with both texlive-fonts-recommended and texlive-fonts-extra

The location path for the files are (summarizing):

$ sudo find / -iname ulg*
/usr/local/share/texmf/tex/latex/ulg/ulgothic.sty
/usr/local/share/texmf/fonts/vf/urw/lettrgth/ulgb*.vf
/usr/local/share/texmf/fonts/afm/urw/lettergothic/ulgb*.afm
/usr/local/share/texmf/fonts/map/dvips/ulg/ulg.map
/usr/local/share/texmf/fonts/tfm/urw/lettrgth/ulgb*.tfm
/usr/local/share/texmf/fonts/type1/urw/lettergothic/ulgb*.pfb

The path for pdftex.map is

$ kpsewhich pdftex.map
/var/lib/texmf/fonts/map/pdftex/updmap/pdftex.map
share|improve this question

closed as too localized by egreg, yo', Qrrbrbirlbel, Kurt, Werner Mar 2 '13 at 21:50

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
Please, can you edit your answer and write down the path to the location of the letter gothic files, just one or two, just to make sure, where they are. And could you have a look at the properties of those files? –  Keks Dose Aug 15 '12 at 7:46
1  
You haven't activated the map-file correctly. Try updmap-sys --enable Map ulg.map. If this doesn't work, show the path of your pdftex.map (kpsewhich pdftex.map). –  Ulrike Fischer Aug 15 '12 at 8:01
    
@KeksDose the location path is now at the question body. I hope that is the information you asked. @Ulrike the updmap-sys command didn't work. I updated the question with the path of pdftex.map. –  Fernando Mayer Aug 15 '12 at 18:23
    
Please see Manual font installation. –  Speravir Mar 2 '13 at 22:51

Browse other questions tagged or ask your own question.