Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I'm having difficulty with references printing using WinEdt + biber. The problem looks just like this post: http://sourceforge.net/projects/biblatex-biber/forums/forum/824416/topic/5413419

Unfortunately, when I re-install MikTEx the problem doesn't go away. I deleted the cache (if the cache is all the files in the folder besides the tex file) and re-installed MikTex and the problem persists.

Specifically the problem is that references are being placed in the pdf intext but no bibliography prints at the end.

I ran this script:

\documentclass[]{article}

\usepackage[autostyle]{csquotes}

\usepackage[
    backend=biber,
    style=authoryear-icomp,
    sortlocale=de_DE,
    natbib=true,
    url=false, 
    doi=true,
    eprint=false
]{biblatex}
\addbibresource{biblatex-examples.bib}

\usepackage[]{hyperref}
\hypersetup{
    colorlinks=true,
}

%% ##############################
\begin{document}
    Lorem ipsum dolor sit amet~\citep{kastenholz}.
    At vero eos et accusam et justo duo dolores et ea rebum~\citet{sigfridsson}.
    \printbibliography 
\end{document} 

And here's the console output:

https://dl.dropbox.com/u/61803503/CONSOLE_OUTPUT.txt

Here's the entire file I ran:

https://dl.dropbox.com/u/61803503/TEST_BIBER.zip

I don't think wWinEdt has anything to do with this. Using windows 7 machine with MikTex 2.9

share|improve this question
1  
Looks like you have broken version of biblatex installed in your local tree here: C:\Users\trinker\AppData\Roaming\MiKTeX\2.9. Your attempts to update/reinstall MiKTeX are probably updating only your main tree here: C:\Program Files (x86)\MiKTeX 2.9. –  Audrey Aug 16 '12 at 22:33
    
This sounds promising, though a right click properties says it was created today. I found the biber file you discussed. How do I replace it if deleting MikTex and reinstalling doesn't do it? –  Tyler Rinker Aug 16 '12 at 22:50
    
Your problem is that you are using biber 0.9 and not version 1.0. HAve you installed MiKTeX as a user or as administrator? Delete and install the complete MikTeX only with your administrator account. –  Kurt Aug 16 '12 at 23:02
    
@TylerRinker OK. My guess was wrong, then. You can delete your local tree. Reinstall isn't necessary - just run the update manager as administrator. –  Audrey Aug 16 '12 at 23:19
1  
@TylerRinker: It should not be necessary to deinstall/reinstall everything. But if you have a multiuser installation then you should always run the update manager in user mode and admin mode so that packages installed as user and packages installed as admin gets updated. (You can also install miktex in your user account "only for you". Then this double update is not needed.) –  Ulrike Fischer Aug 17 '12 at 8:26
show 4 more comments

1 Answer

up vote 1 down vote accepted

You can see in your file test-biber.blg that you are using biber 0.9 (line 1: [0] Config.pm:300> INFO - This is Biber 0.9.9).

You need biber 1.0 to run your version of biblatex. If you have installed MikTeX new does this not mean that all packages are up to date. Update your MiKTeX system using the administrators Update manager of MiKTeX.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.