Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I am some trouble writing a CV using koma-moderncv package. I am running MikTex 2.9 with TexnicCenter RC 1. I have installed the package via the package manager that comes along with MikTex. After doing this I downloaded and opened the example provided at http://ctan.org/pkg/koma-moderncvclassic. With the exception that I modified the options of babel and csquotes I have touched nothing. Never the less I get the following warnings when compiling:

LaTeX Warning: Reference `lastpage' on page 1 undefined on input line 138.

[1


{C:/Users/john.doe/AppData/Local/MiKTeX/2.9/pdftex/config/pdftex.map}]

LaTeX Warning: Reference `lastpage' on page 2 undefined on input line 148.

[2]

LaTeX Warning: Empty bibliography on input line 151.

Package atveryend Info: Empty hook `BeforeClearDocument' on input line 154.
Package atveryend Info: Empty hook `AfterLastShipout' on input line 154.
(C:\Users\john.doe\Documents\Ansoegning\Skabelon\cvbasic.aux)
Package atveryend Info: Executing hook `AtVeryEndDocument' on input line 154.
Package atveryend Info: Executing hook `AtEndAfterFileList' on input line 154.
Package rerunfilecheck Info: File `cvbasic.out' has not changed.
(rerunfilecheck)             Checksum: E64A0148F1EE05FA86DCDCCFFE737411;205.


LaTeX Warning: There were undefined references.


Package biblatex Warning: Please (re)run Biber on the file:
(biblatex)                cvbasic
(biblatex)                and rerun LaTeX afterwards.

The result seems to be that I don't get the correct page-numbering. I am running pdflatex, bibtex, pdflatex, pdflatex. In the bibtex step I get the errors I found no \citation commands---while reading..., I found no \bibdata commands---while reading... and I found no \bibstyle commands---while reading...

Has anyone experienced similar problems and what was the solution?

share|improve this question

closed as too localized by Thorsten, Torbjørn T., Marco Daniel, lockstep, percusse Aug 22 '12 at 3:42

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

2  
Look at the output: Please (re)run Biber on the file. Your using biber and not bibtex. If you want to use the example with bibtex, you have to change the backend=biber in biblatex to backend=bibtex. –  Juri Robl Aug 18 '12 at 14:53
    
Thanks. That solved the issue. –  Nesavi Aug 18 '12 at 20:29

1 Answer 1

It's very important to read the warning message carefully. In your case it's

Package biblatex Warning: Please (re)run Biber on the file:
(biblatex)                cvbasic
(biblatex)                and rerun LaTeX afterwards.

That means you have loaded the package biblatex with the option backend=biber.

So you have to compile with:

(pdf)latex
biber
(pdf)latex
(pdf)latex

instead of bibtex. If you want to compile with bibtex you must change the option backend to bibtex.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.