Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I am trying to install ytableau.sty, following the directions here and here, and in the ytableau README. I am running TexShop 2.47 on OS X 10.6. Here's a walkthrough of what I've done, although I suspect I may have gone wrong early on.

First of all, I don't already have it:

\documentclass{amsart}
\usepackage{ytableau}

\begin{document}

\end{document}

produces

! LaTeX Error: File `ytableau.sty' not found.

Downloaded ytableau.ins from CTAN, ran latex ytableau.ins, created directory ~/Library/texmf/tex and copied resulting ytableau.sty file to it. Test file now produces

LaTeX Warning: You have requested, on input line 173, version
               `2011/06/02' of package pgfopts,
               but only version
               `2008/06/26 v1.0  LaTeX package options with pgfkeys'
               is available.

  ! Undefined control sequence.
  l.174 \ProcessPgfPackageOptions
                                 {/ytableau/options}

Repeated process to install the June 2, 2011 version of pgfopts.

I still get the same error message. I've tried putting pgfopts in a few different places, namely ~/Library/texmf/tex, ~/Library/texmf/tex/pgfopts, ~/Library/texmf/latex and ~/Library/texmf/latex/pgfopts, but either LaTeX is still finding the old version or that wasn't the actual problem.

share|improve this question
2  
The packages should be put in ~/Library/texmf/tex/latex/<packagename>/. To test if they are being found, run kpsewhich <packagefile> (for example, kpsewhich pgfopts.sty). –  Loop Space Sep 5 '12 at 15:14
    
Oh, and help with installation is definitely welcome, but it's highly likely that someone will suggest that you upgrade your TeX distribution as that's almost always a good thing to do. As "almost always" and "always" are not completely synonymous, we recognise that there are circumstances in which that isn't possible. –  Loop Space Sep 5 '12 at 16:07
1  
Well, that was anti-climactically easy. Thanks! @Herbert If you'd like to increase your reputation by 0.1%, leave an answer and I'll be glad to give you the bounty. –  David Speyer Sep 6 '12 at 19:52
    
@DavidSpeyer done ... –  Herbert Sep 6 '12 at 20:08
    
As a very late comment, I suppose I should observe (as the package author) why I insisted on this version of pgfopts. In fact, I received a bug report relating to pgfopts version 1.x, and it seems that version 2.x is really significantly different. So you'd have had an error either way :) –  Ryan Reich May 2 '13 at 6:28

2 Answers 2

up vote 4 down vote accepted
+50

your TeX distribution is out of date, update it ...

share|improve this answer

It seems you are running a rather old version of Tex. I suggest to * download the latest version of MacTeX * install it * make sure that in the TeX preference panel TeX Live 2012 is selected * retry to run your file, the version of pgf* in TL2012 should be new enough

share|improve this answer
1  
didn't I said this already? ;-) –  Herbert Sep 11 '12 at 10:34
    
No, the point is he might use an old MacTeX where there are no updates any longer. We have to make sure that both the latest is installed and activated in the preference pane. –  norbert Sep 12 '12 at 8:41

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.