Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

we are currently experiencing some issues with the ambiguity feature of apa for biblatex/biber (we use biber) in TexLive 2012. What would be correct with the ambiguity feature:

Doe J., Peters M., Kramer N., Conan B. (2012)
Doe J., Mayer M., Smith N., Walker J. (2012)

Citations in text (subsequent ones) - AS IS AND CORRECT
Doe, Peters et al (2012)
Doe, Mayer et al (2012)

But in case of different years, it shouldn't actually do this ...

Doe J., Peters M., Kramer N., Conan B. (2012)
Doe J., Mayer M., Smith N., Walker J. (2009)

Citations in text (subsequent ones) - AS IS:
Doe, Peters et al (2012)
Doe, Mayer et al (2009)

Citations in text (subsequent ones) - HOW IT SHOULD BE:
Doe et al (2012)
Doe et al (2009)

Can anyone help here?

Thank you!

share|improve this question
    
I don't really understand why your last example is correct, that looks like exactly the same list of authors wrote papers in 2009 and 2012, which isn't the case? –  PLK Aug 21 '12 at 6:39
    
Well, it should be correct because the year is already sufficiently clarifying the referenced article/book and therefore there is no ambiguity left. As far as I understood APA, this is also what they require ... –  Juergen Aug 21 '12 at 8:38
    
There are many different ways of disambiguating and you are right that those examples are unambiguous pointers into the references. It seems to be from the APA 6th edition that they intend more than that, that the citations are not ambiguous (they mandate adding initials to disambiguate surnames, for example). If you want to turn this off, you can try "uniquename=false" as a package option. –  PLK Aug 21 '12 at 11:18
    
Okay, I could do that, but then it a) still uses et al only from the 3rd author on (so doing Doe, Peters, et al) and b) APA style still requires me to disambiguate authors names by adding initials if requires, so "uniquename=false" does not work. Any other ideas? It would be great if you could help! –  Juergen Aug 21 '12 at 15:09
    
Try uniquelist=false –  PLK Aug 21 '12 at 15:21
show 1 more comment

1 Answer

What you need to do is set uniquelist=false to turn off automatic name list disambiguation but what you probably want is uniquelist=minyear (thanks for reminding me Audrey) which does exactly what you want - only disambiguates name lists when the labelyear is the same. Technically, this is not APA compliant as they mandate disambiguation of citation name lists in themselves, not just as name+year pointers into the references section.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.