Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I'm new to LaTeX, and have been given a LaTeX draft for writing a thesis. Everything works fine except for this warning:

see the transcript file for additional information)pdfTeX warning (dest): name{ehrenw\366rtliche\040erkl\344rung.1} has been referenced but does not exist, replaced by a fixed one

Here is the position in the code:

\refstepcounter{dummy}  
\pdfbookmark[1]{Ehrenwörtliche Erklärung}{ehrenwörtliche erklärung}  
\chapter*{Ehrenwörtliche Erklärung}  
\thispagestyle{empty}`

When I don't use German Umlauts(ä,ö,ü), i.e.

\pdfbookmark[1]{Ehrenwoertliche Erklaerung}{ehrenwoertliche erklaerung}

it works fine! I don't get any warnings and the link works.

I've been Googling for 2 weeks for similar warnings, and trying things out but none worked. Any one with similar experience or ideas how to get this fixed.

I'm using MAC 10.8 with MacTeX-2012

share|improve this question

migrated from stackoverflow.com Aug 20 '12 at 22:21

This question came from our site for professional and enthusiast programmers.

    
The order in which you load the packages can matter, especially with hyperref. If you are using that, try loading it last. tex.stackexchange.com/questions/1863/… –  yasmar Oct 22 '12 at 15:17
    
I had the same problem. The solution might not apply to you as well, but have a look if there is a \let\clearpage\relax in front of you \printbibliography command. –  math Feb 12 at 9:30

3 Answers 3

I've had a similar problem too, which appears to be related to Poeh's one. I referenced an environment without content

\begin{env}[foo]\label{env:foo}
\end{env}

which produced the following error message

pdfTeX warning (dest): name{env.#} has been referenced but does not exist, replaced by a fixed one

(# denotes the reference number). Apparently, pdfTeX correctly processes an environment only if it has some effective content (besides its name, here: foo). In Poeh's case the content is indeed \hspace{2em} since pdfTeX restarts processing environment contents for each subenvironment (that's why \begin{enumerate} is not sufficient to trigger pdfTeX correct response).

If you didn't change anything else besides the Umlauts, then I suspect the warning message might be caused by a wrongful interaction between pdfTeX and hyperref as suggested above. As you can see in the warning, Umlauts are not correctly interpreted (nor, for sure, they are by hyperref, which also does not interpret math symbols, occasionally prompting warnings such as Package hyperref Warning: Token not allowed in a PDF string (Unicode):(hyperref) removing '\mathgroup' on input line 58.).

This issue is much more difficult to deal with, but, since you are under Mac OS, I'd suggest to change your encoding settings to applemac (rather than UTF8, Unicode or anything else).

share|improve this answer

I've had a similar problem, but I've "solved" it.

Online some people seemed to suggest this is to do with hyperref, but, I'm not convinced. Loading hyperref last had no effect whatsoever.

In the .tex file I had:

\begin{proposition}\label{prop:amG delta in amG delta K}
\begin{enumerate}
\item

This formats so that the 1. of the \item is right next to the "Proposition 3.6" header.

My log file told me:

pdfTeX warning (dest): name{theorem.3.6} has been referenced but does not exist
, replaced by a fixed one

Then, I inserted some space like this:

\begin{proposition}\label{prop:amG delta in amG delta K}
\hspace{2em}
\begin{enumerate}
\item

Now of course the 1. of the \item is below, not next to, the "Proposition 3.6" header, but also, miraculously, the referencing problem is solved!

Don't ask me why, though.

share|improve this answer

Load the bookmark package:

enter image description here

\documentclass{report}
\usepackage[utf8]{inputenc}% http://ctan.org/pkg/inputenc
\usepackage{hyperref}% http://ctan.org/pkg/hyperref
\usepackage{bookmark}% http://ctan.org/pkg/bookmark
\begin{document}
\pdfbookmark[1]{Ehrenwörtliche Erklärung}{ehrenwörtliche erklärung}
\chapter*{Ehrenwörtliche Erklärung} 
\thispagestyle{empty}
\end{document}
share|improve this answer
1  
Hi Werner, Thanks 4 ur answer. Unfortunately it didn't work, i also installed, updated the oberdiek package sudo tlmgr update oberdiek and sudo -i tlmgr update --all, still the link didn't work. when clicking on the chapter it jumps back to the first page. With ur example i get the same warning. My Tex Version: TeX 3.1415926 (TeX Live 2012) kpathsea version 6.1.0 Copyright 2012 D.E. Knuth. –  Fadi Asbih Aug 21 '12 at 9:02

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.