Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I am using memoir package and I want to generally left align tables (In contrast to figures that should be centered). I am using the hmisc latex function which generates this float table code, but I didnt find a way to easily change/discard the center environment:

\begin{table}[!h]
\caption{}
\begin{center}
\begin{tabular}
...content...
\end{tabular}
\end{center}
\end{table}

I already tried the following:

\let\centering\relax

to generally disable centering. My idea is to selectively enable centering for figures. To achieve this I am trying to use the package floatrow but I without any success. Could somebody draft how to either selectively switch off or switch on centering. (Providing I am using the hmisc latex function to generate the table.)

Edit 1: Additional Question: Is there a way (and how) to disable centering (as mentioned using the \let command) but center a figure afterwards somewhere in the document ?

share|improve this question
add comment

1 Answer

The only mention I could find of hmisc is an R package. If you are using R it would have been helpful to say so. Strictly this is off topic for this site as it is an R programming question.

The manual for hmisc is here

http://cran.r-project.org/web/packages/Hmisc/Hmisc.pdf

and on page 149 (or just search for center which is what I did) it says

center=c(’center’,’centering’,’none’),

so I assume you want none.

share|improve this answer
    
Actually I was hoping that there is a way to define a global setup that triggers this kind of positioning for table and figure floats separately. –  user1240076 Aug 22 '12 at 11:28
    
but why get R to put in centering if you don't want it? You can go \let\oldtable\table\def\table{\oldtable\let\center\flushleft\let\endcenter\endf‌​lushleft} but that seems an odd thing to do. –  David Carlisle Aug 22 '12 at 11:40
    
because I have a lot of tables that are already generated using the default. –  user1240076 Aug 22 '12 at 11:43
    
Thanks for the code to redefine the table. It works but it outputs the positioning option of the table environment like: [!h] and [!tbp] just above of each table. –  user1240076 Aug 22 '12 at 11:56
    
sorry move \oldtable to be the last thing not the first thing in the definition of \table. –  David Carlisle Aug 22 '12 at 12:32
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.