Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

Disclosure: my knowledge of LaTeX is extremely limited

I am trying to use pdflatex to convert foo.tex to foo.pdf.

When I first tried this I got error messages saying I was missing calc.sty so I installed texlive-latex-extra.

sudo apt-get install texlive-latex-extra

Then I got error messages saying

! LaTeX Error: File `realcalc.tex' not found

So I installed texlive-generic-extra

sudo apt-get install texlive-generic-extra

and I still get that error message.

I read that it's necessary when packages are install to rebuild the LaTeX package database so I ran texhash but I still get the realcalc error.

Can anyone tell me what I should do to resolve this ?

FWIW the input .txt which I'm trying to convert looks like this :

\documentclass[a4paper]{article}
\usepackage{nzinvoice}
\renewcommand{\InvoiceNumber}{91}
\renewcommand{\CustomerName}{Teast Ltd}
\renewcommand{\DueDate}{September 20, 2012}
\renewcommand{\CustomerAddress}{PO Box 666\\
Somewhere\\
Someplace
}

\begin{document}
\begin{invoice}{NZ\string$}{0}
  \ProjectTitle{}
  \vfill
  \Fee{Doughnuts}{2500.00}{1}
\end{invoice}
\end{document}

After Herbert's answer:

Herbert I grabbed the file from CTAN . But I found there was no $TEXMFLOCAL/tex/generic/realcalc as you can see below (I mean I could create those directories subsidiary to $TEXMFLOCAL but I didn't think that was what you intended ?):

glauc@ubserver1:~/texmf$ kpsewhich -var-value TEXMFLOCAL
/usr/local/share/texmf
glauc@ubserver1:~/texmf$ cd /usr/local/share/texmf
glauc@ubserver1:/usr/local/share/texmf$ ls -lrt
total 8
drwx--S--- 2 root staff 4096 Aug 22 23:29 lsR16767.tmp
-rw-rw-r-- 1 root staff   81 Aug 23 10:01 ls-R
glauc@ubserver1:/usr/local/share/texmf$

So after that I thought I would fall back to trying your non-root version.

glauc@ubserver1:/usr/local/share/texmf$ kpsewhich -var-value TEXMFHOME
/home/glauc/texmf

So I created the texmf directory and unpacked the .zip from CTAN there to make a structure like this :

glauc@ubserver1:~$ ls -lR ~/texmf
/home/glauc/texmf:
total 16
drwxr-xr-x 2 glauc glauc 4096 Aug 23 12:51 realcalc
-rw-rw-r-- 1 glauc glauc 6648 Sep 25  2005 realcalc.zip

/home/glauc/texmf/realcalc:
total 36
-rw-r--r-- 1 glauc glauc  1456 Feb 15  1993 readme
-rw-r--r-- 1 glauc glauc 14159 Feb 15  1993 realcalc.tex
-rw-r--r-- 1 glauc glauc    98 Feb 15  1993 realdemo.tex
-rw-r--r-- 1 glauc glauc  8796 Feb 15  1993 realtest.tex

And I then did a texhash from /home/glauc/texmf specifying both . and ./realcalc as directories to process.

Sadly nothing has changed !

If you can see anything I'm obviously doing wrong here I'd be be grateful to hear !

share|improve this question

1 Answer 1

the file isn't part of the TeXLive distribution. Get it from CTAN: ftp://mirror.ctan.org/macros/generic/realcalc.zip and save it into $TEXMFLOCAL/tex/generic/realcalc. Then run texhash and it should be found by kpsewhich realcalc.tex. The directory for TEXMFLOCAL can be found with kpsewhich -var-value TEXMFLOCAL. If you have no root access then install it under TEXMFHOME kpsewhich -var-value TEXMFHOME, which is often $HOME/texmf

share|improve this answer
    
OK, thank you very much for that. I appreciate it. I've still got problems and I'm about to amend the question to explain those. If you were willing to comment on those that would be great. –  glaucon Aug 23 '12 at 0:39
    
the directory should be /home/glauc/texmf/tex/generic/realcalc –  Herbert Aug 23 '12 at 5:18
    
Thanks very much for that. I don't have time to try that right during today but I will have a go. Thanks again for your helpful comments. –  glaucon Aug 24 '12 at 1:56

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.