Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I'm trying to reference a long URL in a footnote. I'm usig hyperref-package (which loads automatically the url-package).

\usepackage[unicode=true, 
bookmarks=true,bookmarksnumbered=true,bookmarksopen=true,bookmarksopenlevel=1,
breaklinks=false,pdfborder={0 0 0},backref=false,colorlinks=false]
{hyperref}
\urlstyle{rm}

My footnote looks like this:

\footnote{\url{https://www.apple.com/pr/library/2008/04/03iTunes-Store-Top-Music-Retailer-in-the-US.html} - besucht 14.08.2012}

The URL is seperated in 2 linex, but the first line is on one page and the second line is on the next page. Page1 Page2

Do you know how i can fix that issue?

share|improve this question
    
the first footnote is mentioned in the last line of page 95. the second footnote is at the beginning of page 96. –  simon Aug 22 '12 at 13:20
1  
These are tough problems: probably your footnote marker is in the last line, leaving space only for one line of the footnote, while moving the marker to the next page would make an underfull page. Try rephrasing the text. –  egreg Aug 22 '12 at 13:31
add comment

2 Answers

up vote 4 down vote accepted

It is difficult to reproduce the behaviour, but I have following suggestions:

  1. Try loading the package bigfoot, which does wonder to the layout of footnote.

  2. Try add the command \enlargethispage{\baselineskip} to add one line to the type block, or \enlargethispage{-\baselineskip} to reduce the actual type block one line.

  3. Try rephrasing the text so you can have the footnote reference another place in the sentence and on the page.

  4. Try adding a \nopagebreakat the end of the footnote.

    \footnote{\url{https://www.apple.com/pr/library/2008/04/03iTunes- Store-Top-Music-Retailer-in-the-US.html} - besucht 14.08.2012 \nopagebreak}

share|improve this answer
    
"enlargethispage{-\baselineskip}" has made it :) thank you –  simon Aug 22 '12 at 13:49
add comment

Setting

\interfootnotelinepenalty=10000

should prevent all footnotes from breaking over a page.

share|improve this answer
    
Is it possible to make that command local to one footnote? Normally, if you have several long footnotes, it may be not desirable to hinder all footnotes to split (may give ugly layout) –  Sveinung Aug 22 '12 at 13:56
1  
yes it can be set anywhere locally and just works in that scope so any surrounding environment would scpe it or `\interfootnotelinepenalty=10000 \footnote{...}} if you just want one. –  David Carlisle Aug 22 '12 at 14:35
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.