Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

My babel configuration includes ngerman and english ...

\documentclass[
oneside, openright, titlepage,
dottedtoc, numbers=noenddot,
headinclude, footinclude=true,
cleardoublepage=empty, abstractoff,
BCOR=5mm, paper=a4, fontsize=11pt,
ngerman,
american,
draft
]
{scrreprt}

\PassOptionsToPackage{utf8}{inputenc}
\usepackage{inputenc}
\usepackage[ngerman,english]{babel}
\usepackage[pdfspacing]{classicthesis}

\begin{document}

% Disable paragraph indentation.
\setlength{\parindent}{0pt}

9. Wie lange benötigen die Personen für die Erfassung/Aktualisierung
der Daten vor Ort und bei der Nachbearbeitung im Büro?\\

10. Verwenden Sie ein kommerzielles Hardware- oder Software-Produkt
für die Verwaltung\\

\end{document}

..., however, the hyphenation seems to be not working correctly, as I can see in draft mode.

German hypenation

Questions:

  • What do I need to configure in order to use auto-hyphenation?
  • Side question: Why do I need to add \\ to get an empty line between 9. and 10.?
share|improve this question
4  
Use \usepackage[english,ngerman]{babel}. Unless you say \selectlanguage later the last language in the option list is active. –  cgnieder Aug 22 '12 at 17:09
2  
Also words with dashes hyphens like Software-Produkt will only be hyphenated at the dash unless you follow @PatrickGundlach's advice and write Software"=Produkt. –  cgnieder Aug 22 '12 at 17:18
2  
You may also want to use \slash instead of the / symbol; this tells LaTeX that it's OK to break the long "word" Erfassung/Aktualisierung after the slash. –  Mico Aug 22 '12 at 17:30
1  
Another addition: I think, actually your problem is, that you already declared languages in the documentclass options. And once again: If you mostly want to use German in your document, you should change the order in the babel or (exclusive or) documentclass options – what Patrick said: Read the babel documentation. –  Speravir Aug 22 '12 at 18:31
1  
Alternatively you could add another shorthand by saying \makeatletter\declare@shorthand{ngerman}{"/}{\penalty\@M/\hskip\z@skip}\makeato‌​ther and then use Erfassung"/Aktualisierung –  cgnieder Aug 22 '12 at 18:49

1 Answer 1

up vote 4 down vote accepted

You have to select the language that is used. So add \selectlanguage{ngerman} in front of German text and \selectlanguage{english}in front of english text.

The hyphenation is not working because LaTeX has problems to hyphenate Erfassung/Aktualisierung correctly. Insert (you are using babel) "- to mark the places a hyphenation can occur.

Use \begin{enumerate} to build well typesetted enumerations.

I added these thing in your MWE:

\documentclass[
oneside, openright, titlepage,
dottedtoc, numbers=noenddot,
headinclude, footinclude=true,
cleardoublepage=empty, abstractoff,
BCOR=5mm, paper=a4, fontsize=11pt,
ngerman,
american,
draft
]
{scrreprt}

\PassOptionsToPackage{utf8}{inputenc}
\usepackage{inputenc}
\usepackage[ngerman,english]{babel}
\usepackage[pdfspacing]{classicthesis}

\begin{document}

% Disable paragraph indentation.
\setlength{\parindent}{0pt}
\selectlanguage{ngerman}
\begin{enumerate}
  \item Wie lange benötigen die Personen für die Erfassung/Aktuali"-sierung 
    der Daten vor Ort und bei der Nachbearbeitung im Büro?
  \item Verwenden Sie ein kommerzielles Hardware- oder Software-Produkt
    für die Verwaltung
\end{enumerate}

\end{document}
share|improve this answer
    
I noticed that only the combination \selectlanguage{ngerman} of "- works. @cgnieder I could not experience any influence on the hyphenation by the order babel received its language options. @Kurt I quote plain text emails and therefore will not format them with a list. Thank you anyways. –  JJD Aug 22 '12 at 18:05
    
@JJD when you remove the american/ngerman from the global option list, you can see the differences in the order for babel by using the "= and similar shorthands. –  topskip Aug 22 '12 at 18:07
    
@PatrickGundlach When I use \usepackage{babel} with \selectlanguage{ngerman} and put "= or "- it still works. Sorry for my confusion. –  JJD Aug 22 '12 at 18:16
    
There is a problem with using language class options and babel. It depends on the sequence of calling languages. The best way is allways to use \selectlanguage. babel then activates the shortcuts. You can also use \-` independent from babel. –  Kurt Aug 22 '12 at 18:22
    
@Kurt Cute. I find \- even more convenient. Why should I use the others? But it also requires \selectlanguage{ngerman} as I experienced. –  JJD Aug 22 '12 at 18:30

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.