Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

My header is as follows:

\documentclass[11pt,a4paper,sans]{moderncv}
\usepackage[latin1]{inputenc}
\usepackage[ngerman]{babel}
\usepackage[T1]{fontenc}
\usepackage{lmodern}
\usepackage{amsmath, amssymb}
\usepackage{enumerate}
\usepackage{dsfont}
\usepackage{bibgerm}

\moderncvtheme[red]{classic}
\usepackage[left=25mm,right=25mm, top=30mm, bottom=30mm]{geometry}
\renewcommand{\baselinestretch}{1.25}

\AtBeginDocument{\recomputelengths}

\nopagenumbers{}                            

\begin{document}

\makecvtitle

\nocite{*}
\newpage
\section{Literatur}

\small{\makeatletter
\renewcommand*\bibliographyitemlabel{\@biblabel{\arabic{enumiv}}}
\makeatother

\bibliographystyle{plain}
\bibliography{xy}}

\end{document}

I want to include a Bibliography:

\makeatletter
\renewcommand*\bibliographyitemlabel{\@biblabel{\arabic{enumiv}}}
\makeatother

\bibliographystyle{plain}
\bibliography{xy}

But now, this bibliography is in English and I want to have it in German. The authors are separated by and, but it should be German (und). So how to change the language in the Bibliography?

Even if I put \bibliographystyle{gerplain} I get und instead of and, but then the first and surname are switched.

I tried the example below. Didn't work. So I try to put up an example of an entry in my bibfile:

@book{...,
author="... and ...",
title={{title}},
language="English",
publisher="{}",
year=""
}
@article{...,
author="... and ...",
title={{xyz.}},
language="English",
journal="...",
volume="",
number="",
pages="",
year=""
}

I just don't know what to do anymore. Tried all I could find while searching on google and other platforms.

share|improve this question
    
Use the package bibgerm in combination with the German version of plain: gerplain. –  Marco Daniel Aug 23 '12 at 18:24
    
So I changed to "bibgerm", but "gerplain" is not working. I get mistakes and prename and surname of the authors are in wrong position. What else can one do? –  maad Aug 23 '12 at 18:41
    
Not working? What do you mean? Please provide complete minimal working example. –  Marco Daniel Aug 23 '12 at 18:46
    
So if I put "gerplain" I get the wanted ----und---- –  maad Aug 23 '12 at 19:30
    
Oups: Only the first and surname of the FIRST AUTHOR are switched, separated by "," –  maad Aug 23 '12 at 19:32
show 1 more comment

1 Answer

I do not have your bib file (update your question and add it please), so please test the following MWE by your own (on my systen it runs):

%http://tex.stackexchange.com/questions/68484/how-to-change-language-in-the-bibliography
\documentclass[11pt,a4paper,sans,ngerman]{moderncv}

\usepackage{lmodern}
\usepackage[latin1]{inputenc}
\usepackage[T1]{fontenc}

\usepackage[english,ngerman]{babel}

\moderncvtheme[red]{classic}

\firstname{John}
\familyname{Doe}
\address{Strasse Hausnummer}{PLZ Ort}
\mobile{+1~(234)~567~890}
\phone{+2~(345)~678~901}
\email{john@johndoe.de}
\homepage{www.johndoe.de}

\begin{document}

\selectlanguage{ngerman}

\makecvtitle

\nocite{*}
\small{\makeatletter
\renewcommand*\bibliographyitemlabel{\@biblabel{\arabic{enumiv}}}
\makeatother

\bibliographystyle{plaindin} % gerplain alphadin, plaindin, abbrvdin, unsrtdin
\bibliography{mybib}         % Literaturverzeichnis

\end{document} 

I use the English (for literatur) and the German languages (German CV), see document class option, babel and \selectlanguage. I use the German bibliography style plaindin so I have not to load the rather old bibgerm.

I deleted the lines in your MWE which are not neccecary for a minimal working example and added some which were missing in your MWE.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.