Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I'm trying to change the size of footnote marker in the text, making it smaller, but no success.

Here is what I have in preamble: (slightly changes example from memoir class which I'm using)

\renewcommand{\@makefnmark}{\hbox{\textsuperscript{\tiny{\@thefnmark}}}}

but at compilation time all I get is

l.16 \renewcommand{\@makefnmark}
                                {\hbox{\textsuperscript{\tiny{\@thefnmark}}}}
? 

and no effect.

What am I doing wrong? Is there other way to explicitly change the size of footnote marker from normal text size to smaller?

share|improve this question
    
Maybe the superiors package is something for you. –  cgnieder Aug 24 '12 at 12:33
1  
You need to enclose your redefinition in \makeatletter ... \makeatother –  Sašo Živanović Aug 24 '12 at 12:39
    
@SašoŽivanović I've been doing that all the way long, but nothing changes... –  Andrey Aug 24 '12 at 12:46
    
hmm... I'll post my document. –  Sašo Živanović Aug 24 '12 at 12:51
2  
Welcome to TeX.SX! You should indeed add a fully compilable minimal working example (MWE). Also there should be an error message in the line before l.16 \re.... –  canaaerus Aug 24 '12 at 12:52
add comment

1 Answer

This works for me, both for memoir and article class.

\documentclass{memoir}

\makeatletter
\renewcommand{\@makefnmark}{\hbox{\textsuperscript{\tiny{\@thefnmark}}}}
\makeatother

\begin{document}
Some text.\footnote{A footnote.}
\end{document}
share|improve this answer
    
Thank you very much. Your example works perfectly. Though in my case it does not even when relevenat part is copypasted from your code... Guess in my case I need to disable certain packages/options and search for clash. But nevertheless it is weird.. Thank you once again. –  Andrey Aug 24 '12 at 14:19
    
Hello once again. Well everything boiled down to XeTeX, unfortunately, xunicode was the reason somehow. As soon as I switched back to pdflatex, the abovementioned code worked perfectly... –  Andrey Aug 24 '12 at 17:12
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.