TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I may miss something: I cannot produce really greyscale or monochrome pdf. If I create a very simple document, say Hello, with no or basic packages, article or book, and compile it with pdflatex (which I need to use for my project), the pdf appears as greyscale in Texmaker viewer, but not in Acrobat or Foxit readers. It is rich black (RGYK). I have another document, compiled by someone else with pdflatex or pdftex, which appears greyscale OK in Acrobat. It is the same even if I add \usepackage[greyscale]{xcolor}. I am working with Windows and usually compile with TexnicCenter (but TeXMaker does the same). Any idea ?



share|improve this question
May we know why exactly you need the PDF to be "greyscale" and not "colorfull and using only greyscale colours"? – yo' Aug 24 '12 at 14:05
I don't see any problem in the mwe, I also tried with \color{yellow}{Hello} no change. How do you check whether it's grayscale or not? – percusse Aug 24 '12 at 14:10
I need to give it to a professional printer, who absolutely needs it in greyscale or monochrome, not RGYK. – Manchot Aug 24 '12 at 14:15
I simply test with the free software La Boite a couleurs (with a document in pure greyscale I see only grey and black pixels, with a document in rich black, colored pixels appear on the margin of letters). With my MWE,\color{yellow}{Hello}appears black all right on the screen, but it is rich black for me... – Manchot Aug 24 '12 at 14:27
I doubt a printer who would complain about such a thing is very professional... It should be a click for them to configure in the RIP. – Stephan Lehmke Aug 24 '12 at 14:48

I don't understand your problem: Here's a version of your MWE that I modified to produce an uncompressed PDF without any fonts embedded (just to make it easier to look at the PDF in a text viewer/editor, it won't affect the colour spaces):

\usepackage{mathptmx} % use times font
\pdfcompresslevel=0   % don't compress the PDF
\pdfmapline{ptmr8r Times-Roman <8r.enc} % don't embed times font


If you look at the resulting PDF (eg open it in a text editor) you can see that the text is produced by the following:

0 g 0 G
/F16 9.9626 Tf 139.746 706.129 Td [(Hello)]TJ 154.421 -615.691 Td [(1)]TJ

The part 0 g 0 G sets the text to /DeviceGray black: this is a pure black, not a rich black. Changing to \usepackage[cmyk]{xcolor} the corresponding code becomes 0 0 0 1 k 0 0 0 1 K which corresponds to a /DeviceCMYK pure black (CMY components are all zero), so still not a rich black.

Adobe acrobat pro preflight and output preview tools agree with me that these options give /DeviceGray black and /DeviceCMYK non-rich black respectively.

So, I think everything is OK with this MWE. Please check with your full document if there is really a problem, and update the MWE to demonstrate it if so.

share|improve this answer
I have got the same results as you. But the professionnal printer says the text is CMYK and not Black. With my simple La Boite a couleur tool, I can see that the figures (.eps) that were provided to me as greyscaled have only grey pixels on the final pdf, but my text (produced like the Hello) has coloured pixels, like the Hello. Maybe my vocabulary about what sort of black I need was not precise enough. – Manchot Aug 24 '12 at 16:22
@Manchot, either: 1) there is something else going on in the full document that is not showing up in the MWE; 2) your printer is asking for something more than just "pure \DeviceGray black"; or 3) your printer is simply wrong. – Lev Bishop Aug 24 '12 at 16:30
@Lev Bishop. Good diagnostic. I got back to the printer via the editor, and it seems that an old file was handed to him by the editor. Thus grayscale or monochrome options work fine. Thanks for your answers, it helped me to stop searching and go back to the printer. – user18233 Aug 31 '12 at 14:24
@Manchot, maybe the colored pixels in your text come from subpixel rendering in your PDF viewer. – Fritz Aug 31 '12 at 14:48

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.