Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I'm using Kile to edit LaTeX code.

When I press Return to get a new line, Kile does create a new line but automatically adds a tabulation (an indentation) at the beginning of the new line. This happens regardless of whethere there are trailing spaces after the cursor when I press Return.

This is quite annoying (especially when I paste things, it adds additional tabs, and I end up with a pyramid of indents...)

I have tried to change the indentation mode to "None" (and other values e.g. Python) to no avail. Any suggestions on the options I should look at? I tried a lot of them, but I'm not sure which one is the correct one. (Or could it be a bug?)

share|improve this question
    
I cross-posted this on Stack Exchange. I hope it's not bad manners. –  Peutch Aug 24 '12 at 16:58

1 Answer 1

up vote 1 down vote accepted

OK, it's a bit tricky. Go to Settings > Configure Kile; under Editor > Open/Save > Modes & Filetypes, change "Indentation Mode" to None. Then you have to close Kile, and when reopen, in a new file, there will be no auto-indentation.

share|improve this answer
    
Thank you. Does this mean that for files I've already worked on, I'm stuck with the auto-indentation? –  Peutch Aug 25 '12 at 13:40
    
Ha! It seems to work on old files too (after relaunch). Thanks!! –  Peutch Aug 25 '12 at 14:15

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.