Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I'm using XeLaTeX to compile my document. If I write in my document --- I don't get , but --- in my PDF document. Same for (--) character. I'm sure that font which I'm using have this character (Myriad Pro). Are there other ways to get this characters working?If copy&paste this character, it works then. But never when using -- or --- shortcuts.

share|improve this question
1  
\textendash maybe? –  azetina Aug 24 '12 at 17:34
add comment

1 Answer

up vote 7 down vote accepted

You must use the option Ligatures=TeX when declaring the font. See the documentation of fontspec.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.