Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I have a table of contents and I use the glossaries package to make my glossaries. At some point in my code, I have the command \printglossary[type=glossarytype] which prints my glossary. The problem is the glossary word in my table of contents is not aligned with my chapters (which are numbered). I need my glossary entry in ToC to have a little space at the left, where would normally go a chapter number.

share|improve this question

migrated from stackoverflow.com Aug 25 '12 at 15:59

This question came from our site for professional and enthusiast programmers.

1  
Welcome to TeX.sx! Your question was migrated here from another stackexchange site. Please register on this site, too, and make sure that both accounts are associated with each other (by using the same OpenID), otherwise you won't be able to comment on or accept answers or edit your question. –  lockstep Aug 25 '12 at 16:21
add comment

2 Answers

If you must have it like that, I guess you could remove [toc] from the package declaration; create a new chapter called 'Glossary' and \printglossary[type=glossarytype] there. There may be a "better" way, but that'd do it for ya.

share|improve this answer
add comment

Use the package option numberline (in addition to toc).

\documentclass{report}

\usepackage[toc,numberline]{glossaries}
\makeglossaries

\newglossaryentry{electrolyte}{name=electrolyte,%
    description={solution able to conduct electric current}}

\begin{document}

\tableofcontents

\chapter{foo}

Some text about \gls{electrolyte}.

\printglossaries

\end{document}

enter image description here

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.