Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

In the header of my document I set the maximal author names to 2:

\usepackage[style=authoryear-icomp, maxbibnames=9, maxcitenames=2, backend=biber]{biblatex}

Now, when I cite texts with two authors, LaTeX gives me the following:

(Author_A/ Author_B 2012: 232)

When I have three authors or more, LaTeX makes it:

(Author_A/ Author_B et al. 2012: 232)

But I want LaTeX to just name the first author if there are more than two authors ... like this:

(Author_A et al. 2012: 232)

Any tips on how to achieve this ?

share|improve this question
add comment

1 Answer

By default biblatex will truncate name lists exceeding maxcitenames to one author plus "et al." (mincitenames=1). However, biblatex will (also by default) not truncate if doing so would cause ambiguous citation keys, which I suspect is the case in your document. Compare the output of the following two examples:

\documentclass{article}

\usepackage[style=authoryear-icomp,maxbibnames=9,maxcitenames=2,backend=biber]{biblatex}

\usepackage{filecontents}

\begin{filecontents}{\jobname.bib}
@misc{ABC01,
  author = {Author, A. and Buthor, B. and C},
  year = {2001},
  title = {Alpha},
}
\end{filecontents}

\addbibresource{\jobname.bib}

\begin{document}

Some text \autocite{ABC01}.

\printbibliography

\end{document}

enter image description here

\documentclass{article}

\usepackage[style=authoryear-icomp,maxbibnames=9,maxcitenames=2,backend=biber]{biblatex}

\usepackage{filecontents}

\begin{filecontents}{\jobname.bib}
@misc{ABC01,
  author = {Author, A. and Buthor, B. and C},
  year = {2001},
  title = {Alpha},
}
@misc{ADE01,
  author = {Author, A. and Duthor, D. and E},
  year = {2001},
  title = {And now for something completely different},
}
\end{filecontents}

\addbibresource{\jobname.bib}

\begin{document}

Some text \autocite{ABC01}.

Some text \autocite{ADE01}.

\printbibliography

\end{document}

enter image description here

If you only want one author in citation keys under all circumstances, use the option uniquelist=false. (Note that this may lead readers to the false conclusion that "Author et al." refers to the same author team.)

\documentclass{article}

\usepackage[style=authoryear-icomp,maxbibnames=9,maxcitenames=2,uniquelist=false,
    backend=biber]{biblatex}

\usepackage{filecontents}

\begin{filecontents}{\jobname.bib}
@misc{ABC01,
  author = {Author, A. and Buthor, B. and C},
  year = {2001},
  title = {Alpha},
}
@misc{ADE01,
  author = {Author, A. and Duthor, D. and E},
  year = {2001},
  title = {And now for something completely different},
}
\end{filecontents}

\addbibresource{\jobname.bib}

\begin{document}

Some text \autocite{ABC01}.

Some text \autocite{ADE01}.

\printbibliography

\end{document}

enter image description here

share|improve this answer
    
That was just the Information I needed. Thanx a lot! –  Carry White Aug 27 '12 at 18:11
3  
@CarryWhite: If this answer solved your problem/question, consider marking it as ‘Accepted’ by clicking on the tickmark below their vote count (see How do you accept an answer?). This shows which answer helped you most, and it assigns reputation points to the author of the answer (and to you!). –  Werner Aug 27 '12 at 18:17
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.