TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Using the scrartcl class for a report I am writing, I would like to have only the sections show up in the table of contents. Although I manage to do that, the linespread looks too big in my eyes, and I think this is a consequence of the reduced toc depth:

alt text

For this reason, I would like to reduce the linespread locally. I tried to put a {spacing} around my code like this:


Which will not work, however. What is the easiest way to decrease the linespread here?

share|improve this question
up vote 6 down vote accepted

You could use the tocstyle package that comes with the KOMA Script bundle. But you will get a warning about the Alpha state of the package so you should use it with caution. At least the below code works as desired.


  \settocfeature[1]{entryvskip}{0pt plus 2pt}%



And as always, the blindtext package is only for creating dummy text thus not part of the solution.

alt text

share|improve this answer
The package generating the alpha warning is named tocstyle. – lockstep Dec 11 '10 at 21:28
Thanks. Corrected. – Thorsten Donig Dec 11 '10 at 21:31
That leaves nothing unanswered. Thanks! – Ingo Dec 12 '10 at 10:26

You may use the etoolbox package to patch the command \l@section which is (beside other things) responsible for setting the vertical space before a section entry in the ToC.










share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.