Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I'd like to do this for some of my sections but not all. I'd also like to maintain the current spacing; for example, if the vspacing is 1cm from section title to body text (at 100% zoom), then I'd like it to be 1cm from the subtitle to body text.

Thanks.

share|improve this question
3  
Should this subtitle be part of the title (as in, appear in contents)? If so, why not simply use something like \section{Section Title\\Section Subtitle}? –  ℝaphink Aug 31 '12 at 10:41
    
That's a nice option. I tried it and it looks OK, but I'd like to have the subtitle in a smaller font that the title. Thing is, when I use \section{Section Title\\ \large{Section Subtitle}}, it makes the Section Subtitle into large in the TOC. –  User 17670 Aug 31 '12 at 10:58
1  
Then perhaps you can play with the short title argument of the \section command: would \section[Section Title\\ Section Subtitle]{Section Title\\ \large{Section Subtitle}} be what you are looking for ? –  Corentin Aug 31 '12 at 11:04
    
Yes, that works excellently! And, it also gives me the option to remove the "Section Subtitle" argument from the [...]. Thanks all. –  User 17670 Aug 31 '12 at 11:12

1 Answer 1

up vote 12 down vote accepted

If the section's subtitle has to show up in the TOC, then use:

\documentclass[10pt]{article}
\begin{document}
\tableofcontents
\section[Section Title. Section Subtitle]{Section 
   Title\\ {\large Section Subtitle}}
\section{Another Section}
\end{document}
share|improve this answer
    
Thanks! See comments above. –  User 17670 Aug 31 '12 at 11:18
    
@User17670 - In my solution, I suggest not using a line break but simply a period (full stop) to separate the main title and subtitle. –  Mico Aug 31 '12 at 12:15
    
Yes, I noticed. Thanks for the input(!), although I already had a solution (which IMO looks better) from Corentin Herbert. Also, I changed \document class to \documentclass in your post :p –  User 17670 Aug 31 '12 at 12:54

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.