Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

Following this discussion, I have just converted a table using excel2latex, and I get the following output from it,

% Table generated by Excel2LaTeX from sheet 'Sheet2'
\begin{table}[htbp]
  \centering
  \caption{Add caption}
    \begin{tabular}{rrcccccc}
    \addlinespace
    \toprule
          &       & \multicolumn{2}{c}{VC-A} & \multicolumn{2}{c}{VC-B} &     \multicolumn{2}{c}{Difference (\%)} \\
    \midrule
    \multicolumn{2}{c}{Patterns} & Average Iterations & Maximum  Iterations & Average Iterations & Maximum  Iterations & Average & Maximum \\
    \multicolumn{1}{c}{\multirow{4}[8]{*}{Bullish}} & \multicolumn{1}{c}{1} & 29.29 & 70    & 26.30 & 30    & 11.37 & 133 \\
    \multicolumn{1}{c}{} & \multicolumn{1}{c}{2} & 29.11 & 76    & 25.58 & 30    & 13.80 & 153 \\
    \multicolumn{1}{c}{} & \multicolumn{1}{c}{3} & 32.91 & 75    & 27.52 & 30    & 19.59 & 150 \\
    \multicolumn{1}{c}{} & \multicolumn{1}{c}{4} & 33.65 & 76    & 28.16 & 30    & 19.50 & 153 \\
    \multicolumn{1}{c}{\multirow{4}[8]{*}{Bearish}} & \multicolumn{1}{c}{1} & 29.42 & 73    & 26.26 & 30    & 12.03 & 143 \\
    \multicolumn{1}{c}{} & \multicolumn{1}{c}{2} & 28.98 & 73    & 25.49 & 30    & 13.69 & 143 \\
    \multicolumn{1}{c}{} & \multicolumn{1}{c}{3} & 32.92 & 80    & 27.47 & 30    & 19.84 & 167 \\
    \multicolumn{1}{c}{} & \multicolumn{1}{c}{4} & 33.71 & 80    & 28.09 & 30    & 20.01 & 167 \\
    \bottomrule
    \end{tabular}%
  \label{tab:addlabel}%
\end{table}%

I have the bookends and array packages installed. I get an error saying

! Undefined control sequence.\@sharp ->\multirow{4}[8]{}{Bullish} ...column{1}{c}{\multirow{4}[8]{}{Bullish}}

Any ideas? Many thanks.

share|improve this question

1 Answer 1

You need to include the follwing packages: booktabs, multicol and multirow:

\usepackage{booktabs, multicol, multirow}

If you dont't want to use the booktabs package, uncheck the "Booktabs-style formatting" checkbox in the export dialog of excel2latex.

share|improve this answer
    
Thanks. If I turn off "Booktabs-style formatting" I get a different error... this time on the new line "\cline{3-8} \multicolumn{1}{r}{} & & \multicolumn{2}{c||}{VC-A} &" I get the usual undefined control sequence... do I need different packages? –  Rob D Aug 31 '12 at 14:45
    
@RobD Please, make a complete M(N)WE. It is difficult to see what is producing the error without. –  Sveinung Aug 31 '12 at 16:07
    
even if you turn off "Booktabs-style formatting" you still need to include the multicol and the multirow package. –  jrast Aug 31 '12 at 18:06

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.