Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I have additional space inside a text [see picture] between paraghraps. Beside of that it is diffrent size [this space]. What's more before Section, and after section title there is additonal space also. Also with diffrent size in diffrent section title. enter image description here enter image description here enter image description here How to fix it?

    \documentclass[openany]{book}
    \usepackage[utf8]{inputenc}
    \usepackage[MeX]{polski}
    \usepackage{xcolor}
    \usepackage{lipsum}
    \usepackage[explicit]{titlesec}
    \usepackage[dotinlabels]{titletoc}
    \usepackage{setspace}
    \onehalfspacing
    \usepackage[protrusion=true,expansion=true]{microtype}
    \usepackage{lettrine}
    \usepackage{titlesec}
    %\titleformat{\section}{\normalfont\bfseries}{\thesection}{1em}{}
    %\linespread{0.9}
    \newlength\BoxWd
    \setlength\BoxWd{0.75cm}
    \newlength\Aux
    \usepackage[left=4.65cm, right=4.65cm, top=4cm, bottom=4.25cm]{geometry}

    % chapter tiltes formatting
    \titleformat{\chapter}[display]
     {\normalfont\sffamily\huge}
     {\renewcommand{\thechapter}{\Roman{chapter}}%
      \settowidth\Aux{\textcolor{white}{\Huge\thechapter}}
      \ifnum\Aux>\BoxWd
        \setlength\BoxWd{\Aux}
      \else\fi
     \hspace*{0.3em}\colorbox{black}{%
     \parbox[c][1.2cm][c]{\BoxWd}{%
      \centering\textcolor{white}{\Huge\thechapter}}}}
      {-1ex}
      {\titlerule\vspace{.7ex}\filleft\MakeUppercase{#1}}
      [\vspace{.2ex}\titlerule]
     \titlespacing*{\chapter}{0pt}{50pt}{80pt}
     \titleformat{\section}
      {\scshape\normalsize\bfseries}{\MySecSquare\ \thesection.}{0.15em}{#1}
       \titlespacing*{\section}{0pt}{2.5pt}{1.5pt}

       \titleformat{\subsection}
       {\normalfont\scshape\normalsize\bfseries}{\MySecSquare\ \thesubsection.} {0.10em}{#1}
      \titlespacing*{\subsection}{0pt}{1.5pt}{0.5pt}

      % formatting for chapter entries in ToC  
      \titlecontents{chapter}
      [3em]{\vspace*{5.5pt}}
      {\small\bfseries{\hspace*{-2.63em}{\chaptername}\hspace*  {5pt}\contentslabel{0.25em}\hspace*{1.25em}}}
      {\hspace*{-3em}}
      {\titlerule*[1pc]{.}\small\sffamily\bfseries\contentspage}

      % formatting for section entries in ToC  
      \titlecontents{section}
      [4em]{\vspace*{-2pt}}
      {\small\contentslabel{2.5em}}
      {\hspace*{2.75em} }%\hspace*{-2.3em}
      {\titlerule*[1pc]{.}\small\sffamily\contentspage}

      \titlecontents{subsection}
      [7em]{\vspace*{-2pt}}
      {\small\contentslabel{2.85em}}
      {\hspace*{6em}}
      {\titlerule*[1pc]{.}\small\sffamily\contentspage}

      \newcommand\MySquare{%
      \leavevmode\hbox to 1.2ex{\hss\vrule height .9ex width .7ex depth -.2ex\hss}}

      \newcommand\MySecSquare{%
      \leavevmode\hbox to 1.2ex{\hss\vrule height 1.3ex width 1.1ex depth -.2ex\hss}}

      \renewcommand\labelitemi{\MySquare}

      \newenvironment{myquote}{\list{}{\leftmargin=15pt\rightmargin=0.0pt}\item[]}{\endlist}
      \newcommand\MyTitle{Some title}
      \usepackage{fancyhdr}
      \fancyhf{}
      \fancyhead[EL,OR]{\thepage}
      \fancyhead[OL]{\scriptsize\scshape{\leftmark}}
      \fancyhead[ER]{\footnotesize\scshape{\MyTitle}}
      \renewcommand\headrulewidth{0.2pt}


      \pagestyle{fancy}

      \newcommand{\initial}[1]{%
        \lettrine[lines=2,lhang=0.35,nindent=0em]{
                    \color{black}
                    {{#1}}}{}}
       \renewcommand\chaptermark[1]{\markboth{\thechapter.\ #1}{}} 
        \usepackage{hyperref}
       \hypersetup
        {   
        colorlinks,
        citecolor=black,
        filecolor=black,
        linkcolor=black,
        urlcolor=black,
        pdfauthor = {Pdfautor},
        pdftitle = {My title},
        pdftex
         }

         \begin{document}

        \frontmatter

        \tableofcontents
        \clearpage

        \newpage
        \thispagestyle{empty}



        \mainmatter
        \chapter*{Na wstępie}\label{chap:one}
        \addcontentsline{toc}{chapter}{\bfseries{Na wstępie}\vspace*{2em}}
        \setcounter{page}{9}

        \section{Section One}
        \lipsum[1-10]
        \section{Section two}
        \lipsum[1]
        \section{Section 3}
        \section{Section 4}
        \lipsum[1-10]
        \section{Section 5}
        \lipsum[1-2]
        \section{Section 6}
        \lipsum[1]
        \section{Section 7}
        \lipsum[1-20]
        \chapter{Second chapter}
        \section{someSection}
        \lipsum[1-20]
        \section{someSection2}
        \lipsum[1-20]
        \chapter{Last chapter}
        \end{document}
share|improve this question
    
Your given code has none of the marked problems on my system (actual MiKTeX). BTW: package lipsum makes the MWE smaller. BTW2: use a break in your editor after 72 characters per line. You will get better error messages and warnings where the error or warning occurs. Do you have more in your code that is not included in the MWE? –  Kurt Sep 2 '12 at 1:01
    
So You have a tight tex. No space between text? Impossible. I do not want even a milimiter of space where red lines are. It has to be squzed. BTW: As I wrote: I have problems with it. There are many white space, which I can not control. –  Daniel Miliński Sep 2 '12 at 2:19
2  
Do you use \flushbottom in your code? That could be a reason for different space between paragraphs or headings and paragraphs. Does your document change with \raggedbottom? –  Kurt Sep 2 '12 at 2:32

1 Answer 1

up vote 4 down vote accepted

This question was probably answered in the question Making sure that text is aligned between bottoms (and tops) of pages.

Try add the the options paper=a4paper,twoside=true,textheight=45\baselineskip+\topskip

to the geometry-options in your document. You also have to use the package calc

\usepackage{calc}
\usepackage[paper=a4paper,
            twoside=true,
            bindingoffset=0cm,
            textheight=45\baselineskip+\topskip,
            left=4.65cm, right=4.65cm, top=4cm, bottom=4.25cm
            ]{geometry}

In your MWE (but perhaps in the real document), this does not solve the spacing issue because you have to little text after section 0.2, and then two subsections without any text in between. LaTeX does not find a good place to break the page. If you use a real text, or use\lipsum[2-3] after section 0.2, the spaces also disappear. You can also use the command

\enlargethispage{2\baselineskip}

or

\enlargethispage{-\baselineskip}

to add or subtract some lines on the the offending page.

The problem comes from the fact that the book-class use flushbottom as default, and therefore stretch the text between the top and bottom margin. If you add the option raggedbottom to the class option, the problem disappears, permanently.

The moral is: If you want the text flushed between the top and bottom margin, you have to carefully go through the document when you have finished all editing. In that last touch up, you can make subtle changes that correct this type of typesetting errors. But you will no be able to handle all such issued automatically.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.