Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

In srcbook class, no matter how i set top margin (neither geometry nor \addtolength work) it always adds huge space before header. Some people suggested to change @makechapterhead definition but scrbook.cls contain several entries and i don't know which one i have to change.

share|improve this question

closed as too localized by Thorsten, cgnieder, Stephan Lehmke, ℝaphink, Joseph Wright Sep 3 '12 at 9:37

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

1  
Your title says "header" but your question deals with "headings". Be aware that these two terms don't have the same meaning. –  Thorsten Sep 2 '12 at 19:46
    
Have a look at this question: tex.stackexchange.com/questions/15596/… –  Thorsten Sep 2 '12 at 19:50
    
@Thorsten: good point, i meant header like in question title, i'll edit the wrong word. –  Gianluigi Sep 2 '12 at 19:52
1  
Are you sure you don't mean “headings”? I have quite some trouble imagining “huge space before header”. Maybe you could describe your problem in a little more detail? Maybe you could also add a minimal working example? –  cgnieder Sep 2 '12 at 20:02
1  
So what you're actually saying is that you're using the labbook class? You should add an MWE when you have access to your file again (and I still don't know what you mean exactly…) –  cgnieder Sep 2 '12 at 20:33
show 2 more comments

1 Answer

The KOMA-script classes scrbook and scrreprt use \chapterheadstartvskip inside the definition of the headings for \chapter, \part, \addchap, \addpart and their star-variations to insert vertical apace before the chapter heading and the labbook class inherits these setting. The default definition is \addvspace{4ex}; if you want to change this value, redefine the command; the following example shows the necessary redefinition to suppress any extra vertical space between the top margin and the chapter heading (the geometry package with its showframe option was only used to serve as visual reference):

\documentclass{labbook}
\usepackage[showframe]{geometry}
\usepackage{lipsum}

\renewcommand\chapterheadstartvskip{\addvspace{-4ex}}

\begin{document}
\chapter{Test Chapter}
\experiment{Test Experiment}
\lipsum[1-20]
\end{document}

enter image description here

share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.