Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

Possible Duplicate:
Force floats to be typeset after their occurrence in the source text?

I've already found houndreds of useful answers. But I can't find anything about this one. Is there an option/workaround to force latex to move a float only backwards, not "front-wards".

MWE:

\documentclass[a4paper]{scrartcl} 
\usepackage{blindtext}

\begin{document}
\section*{ONE}

\Blindtext

\textbf{Now I am refering} to a float~\ref{float}. Doesn't matter if it's a table or figure; and then I continue the text.
\begin{table}
\begin{tabular}{|p{0.8\linewidth}|}
    \hline
    one \\ two \\ three\\ table shouldn't be too small \\ four \\ two \\ eight \\ real eight \\ \hline
\end{tabular}
\caption{this is one example}
\label{float}
\end{table} 

\blindtext

\end{document}

I know I could use the b and h-placing options. But when my reference is on the end of a page, it's great that latex puts the float in the top-position of the next page. I actually don't care if it places it hbt or p. but I don't want it to "appear too early".

share|improve this question

marked as duplicate by Jake, egreg, diabonas, cmhughes, Harish Kumar Sep 3 '12 at 16:41

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

2 Answers 2

up vote 6 down vote accepted

Use the flafter package. See also http://www.tex.ac.uk/cgi-bin/texfaq2html?label=floats

share|improve this answer

try \begin{table}[!htb] The ! allows TeX to ignore float parameters

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.