Sign up ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I want to use biblatex and I get got an error when using bibtex8 (or other backend, doesn't matter). I already identified the problem: I am using a 'build' direcotry.

So my file stucture is:

/build [all copiled files go here, including myfile.aux and myfile-blx.bib]

in my .tex I have:


which produces the following in the .aux file:


now bibtex8 is run from the base directory with (Texmaker):

bibtex8 --wolfgang build/%

it correctly finds the .aux file and the mybib.bib file but not the -blx.bib file.

I have three workarounds so far:

  • not using a build directory so everything is in one directory (i don't like that)
  • manually copy the -blx.bib file to the parent directory after running (pdf)latex
  • manually editing the .aux file to: \bibdata{build/myfile-blx,mybib}

Obviously none of them desireable.

So how can I get this line in my .aux file automatically?


EDIT 2012-09-04:

@Kurt: Thanks for you tip!

@PLK: I would try to use biber. But I am working with this on two machines. And the main workstation is Windows 7 64 bit, and there is no binary for that on the biber homepage. And the 32 bit does not execute.

@Kurt(2): I am running on [Windows 7, 64 bit, miktex, texmaker, jabref] mainly and also on [xubuntu, 32 bit, texlive, texmaker, jabref].

I personaly think a minimal example is not that helpfull since everything compiles without any errors unless i'am using a build directory. MWE:

\documentclass[a4paper, fontsize=12pt]{scrartcl}
% This file was created with JabRef 2.8.1.
% Encoding: ISO8859_1

  author = {Some Author},
  title = {Fancy Title},
  journal = {Another Journal},
  year = {2010},
  volume = {91},
  pages = {229-261},
  number = {2},
  timestamp = {2012.09.01}

@comment{jabref-meta: selector_review:}

@comment{jabref-meta: selector_publisher:}

@comment{jabref-meta: selector_author:}

@comment{jabref-meta: selector_journal:}

@comment{jabref-meta: selector_keywords:}




Lots of text.



As said above everything runs without any error without a build dirctory. When I use a build directory the first pdflatex run works fine. And then bibtex8 produces the following error/output in the ./build/myfile.blg file:

The 8-bit codepage and sorting file: 88591lat.csf
The top-level auxiliary file: build/myfile.aux
The style file: biblatex.bst
I couldn't open database file myfile-blx.bib
---line 4 of file build/myfile.aux
 : \bibdata{myfile-blx
 :                    ,mybib}
I'm skipping whatever remains of this command

This is because it expects myfile-blx.bib and mybib.bib to be both in the parent directory ./. As stated above i can workaround by maually editig the .aux file before running bibtex8. When I do that it runs without errors.

share|improve this question
Try using biber as the backend and see its --outfile and --output_directory options. Run biber --help to see what these do. – PLK Sep 4 '12 at 6:50
I edited the question with the requested information. As stated there there I run win7, 64 bit. And the biber binary form their website doesn't run – Filo Sep 4 '12 at 8:37
I tried again with downloading biber. This time it is runnable with the 32bit version on my 64 bit machine and doesn't crash. The --output_directory option does the trick! Thanks. Problem solved :D – Filo Sep 4 '12 at 14:21
Ok good, there is no 64bit version specifically as the 32bit should work fine. – PLK Sep 4 '12 at 14:26

1 Answer 1

The --output_directory option of biber deals with this.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.