Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I writing an article using the amsart document class and whenever I use \begin{figure}...\end{figure} to put a figure into the article, it places the figure at the top of the page (which is fine), but leaves an extra space between the paragraphs.

To be more specific:

Paragraph zero text...
Paragraph one text...
begin{figure}...\end{figure}
Paragraph two text...
Paragraph three text...

Produces:

Figure
Paragraph zero text...
Paragraph one text...

Paragraph two text...
Paragraph three text...

When I intend to have the paragraphs follow the same spacing as the others:

Figure
Paragraph zero text...
Paragraph one text...
Paragraph two text...
Paragraph three text...

Is there a way to adjust the document setting so that that extra space does not appear?

Edit: Preamble and specific code:

\documentclass[reqno]{amsart}
\usepackage{amssymb,latexsym}
\usepackage{graphicx}
\usepackage{setspace}
\usepackage{cite}
\usepackage{fullpage}
\usepackage{subfig}
\captionsetup[subfigure]{margin=0pt, parskip=0pt, hangindent=0pt, indention=0pt, labelformat=parens, labelfont=rm}
\newtheorem{theorem}{Theorem}
\newtheorem{lemma}{Lemma}
\newtheorem{definition}{Definition}
\newtheorem{notation}{Notation}
\linespread{1.6}
\begin{document}
...vertices arranged in a circle, one of Dante's favorite Euclidean shapes. 

\begin{center}
\begin{figure}
\includegraphics[width=5.5in,height=5.5in]{graphn33} 
\caption{A complete graph with 33 people in heaven, $K_{33}$.}
\label{fig:graphn33} 
\end{figure}
\end{center}

This highly mathematical object displays...
\end{document}

If I don't have the spacing between the figure code and the paragraphs, the gap still remains but the paragraphs don't indent properly.

share|improve this question
1  
I cannot reproduce the problem. Please add a minimal example of actual code that illustrates your problem. –  Caramdir Dec 12 '10 at 23:32
    
Please provide further information. I just tested it but cannot confirm that behavior. Perhaps post your preamble and what else might be between the two paragraphs in the source code. –  Stefan Kottwitz Dec 12 '10 at 23:43
    
I imagine the problem you are facing is LaTeX formats your document such that the page is vertically justified, if this makes any sense. I know this happens with the book class but I don't know what could be causing that here, since this is amsart. Perhaps, you could post some of your code? In the absence of any further information, however, I would suggest you specify the placement of the figure by passing an optional argument: "[h]" (here) or "[htbp]". The default is "[tbp]" (top/bottom/parse). –  Jimi Oke Dec 13 '10 at 0:00
    
I edited the original question to include specific code. I tested this sample code and it produced the same effect as the entire document. –  Alec Dec 13 '10 at 4:56
    
@Jimi: You shouldn't just use [h]. It will be replaced by [ht] (since it is possible that there is no space for the figure at the specified place). –  Caramdir Dec 13 '10 at 5:10
show 1 more comment

2 Answers 2

up vote 9 down vote accepted

The problem is the center environment. It adds some vertical space, that is not floated to the top because it is outside the figure. You should replace it by \centering inside the figure (inside because you only want it to apply to the figure). \centering doesn't add any space.

\begin{figure}
    \centering
    \includegraphics[width=5.5in,height=5.5in]{graphn33} 
    \caption{A complete graph with 33 people in heaven, $K_{33}$.}
    \label{fig:graphn33} 
\end{figure}
share|improve this answer
    
This was the problem. Thank you. I wish I could upvote you, but I can't until I hit 15 reputation. I'll come back and do so once I hit that. –  Alec Dec 13 '10 at 5:34
1  
@Alec: I did that for you! However, you can and should mark this as the answer to your question so posters know your question has been resolved. –  Jimi Oke Dec 13 '10 at 5:42
add comment

You could try \raggedbottom in your preamble, for the case that it's caused by a \flushbottom or similar setting. During testing, I noticed vertical stretching even with amsart defaults, which have been canceled by \raggedbottom.

share|improve this answer
    
Wow, didn't know the ragged-'s also dealt with vertical alignment! That's one that may come in handy for me in the future. –  Jimi Oke Dec 13 '10 at 0:37
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.