Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I downloaded the moderncv template for LyX, I tried to compile it but this error appears:

\maketitle

Your command was ignored. Type I to replace it with another command, or to continue without it.

If I delete \maketitle it works, but the title, name and so don't appear! I am not able to use LaTeX, I only use Lyx. Please help me!

share|improve this question
1  
Where did you find the moderncv LyX template/layout file? –  Werner Sep 9 '12 at 2:08
    
how can i change the picture from the example? i try for hours. thanks in advance! –  user21061 Oct 18 '12 at 13:11
    
@hanswurst If you have a new question, please ask it by clicking the Ask Question button. Include a link to this question if it helps provide context. –  lockstep Oct 18 '12 at 13:14
    
Did you ever find a solution? I imported a moderncv lyx file to a new computer and "\maketitle" causes troubles. I've been using this lyx file for over 3 years. –  ChrisR Mar 21 '13 at 7:46
add comment

4 Answers

I had same problem, but I found the solution.

In my case, I had \\ in some fields, for example :

\title{
    Administrateur système GNU--Linux \\ Responsable technique.
   }

When I deleted \\, the compilation ran correctly.

\title{
    Administrateur système GNU--Linux Responsable technique.
   }

If there is a \\ string in the fields firstname, familyname, title, address, etc..., the problem appears.

share|improve this answer
add comment

There's probably a problem in Document->Settings->LaTex Preamble, maybe in the address field.

if you see this: \address{Teststreet 17}{03333 Nicecity \\ Switzerland}

try changing it to \address{Teststreet 17}{03333 Nicecity}{ Switzerland}

Goodluck!

share|improve this answer
add comment

For me the problem was the \email declaration. The document compiled after I removed it.

share|improve this answer
add comment

For me both \maketitle and \makecvtitle works fine. Have you set in the preamble something like this?:

\moderncvtheme[blue]{classic}
% possible themes are "classic" and "casual"
% optional argument are 'blue' (default), 'orange', 
% 'red', 'green', 'grey' and 'roman' (for roman fonts,
% instead of sans serif fonts)
\firstname{Long John} % required
\familyname{\\Silver} % required
\title{Curriculum vitae} % optional 
\address{Treasure Island}{Pacific}% optional
\phone{555555555} % optional
\mobile{555555555}% optional
\fax{+43(0)999 7777} % optional
\email{ljsilver@treasureisland.com} % optional
\extrainfo{Pieces of Eight!} %optional
\photo[2 cm]{silverface} % optional
\quote{"Stand by to go about"} % optional
share|improve this answer
    
Yes I have I downloaded everything from the Lyx website. But it's with Lyx not with Latex. A friend of mine told me that maybe I should download some .sty files..do you know something of this?how do you do it? –  user18350 Sep 5 '12 at 20:07
    
In view complete source you can check the packages needed (lines with \usepackage{something}) but most probably you have already these packages. LyX simply export your file to LaTeX to compile, so really is the same. Try to export to LaTeX (= copy the whole source in the viewer and save as a .tex file) and then pdflatex yourfile.tex and the result must be the same PDF. Perhaps is better check that tex file with a text editor to find the problem. –  Fran Sep 5 '12 at 23:28
    
If the code of the previous comment is your preamble in LyX, Disable (put % before) or delete the line-s with \pdfpageheight\paperheight \pdfpagewidth\paperwidth, and all after the \quote{...} command. The \maketitle must be in the beginning of the body of the document (insert it in a ERT box with Ctrl+L) and not in the preamble. –  Fran Sep 5 '12 at 23:45
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.