Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I installed MacTeX 2012 on a freshly installed Mountain Lion. I now would have liked to install some special fonts (Trebuchet, Frutiger etc.). For that I made sure that all the font files are in

~/Library/texmf/

If I run

updmap --enable Map=jtr.map

(or even updmap-sys) I would receive this result:

updmap: resetting $HOME value (was /Users/anouak) to root's actual home (/var/root).
updmap is using the following updmap.cfg files (in precedence order):
  /var/root/Library/texlive/2012/texmf-config/web2c/updmap.cfg
  /usr/local/texlive/2012/texmf-config/web2c/updmap.cfg
  /usr/local/texlive/2012/texmf/web2c/updmap.cfg
  /usr/local/texlive/2012/texmf-dist/web2c/updmap.cfg
updmap is using the following updmap.cfg file for writing changes:
  /var/root/Library/texlive/2012/texmf-config/web2c/updmap.cfg
dvips output dir: "/var/root/Library/texlive/2012/texmf-var/fonts/map/dvips/updmap"
pdftex output dir: "/var/root/Library/texlive/2012/texmf-var/fonts/map/pdftex/updmap"
dvipdfmx output dir: "/var/root/Library/texlive/2012/texmf-var/fonts/map/dvipdfmx/updmap"
pxdvi output dir: "/var/root/Library/texlive/2012/texmf-var/fonts/map/pxdvi/updmap"

ERROR:  The following map file(s) couldn't be found:
    jtr.map (in /var/root/Library/texlive/2012/texmf-config/web2c/updmap.cfg)

    Did you run mktexlsr?

    You can disable non-existent map entries using the option
      --syncwithtrees.

Indeed, I did run mktexlsr and a kpsewhich jtr.map results in:

/Users/anouak/Library/texmf/fonts/map/dvips/jtr.map

So it is there.

I also did a --syncwithtrees to disable the "non-existent" map entries, but unfortunately to no avail.

What is irritating to me is that updmap is trying to use config files in /var/root/ or /private/var/root/ respectively to which even I have rarely access and if then only with difficulties. Also, during my research in the web I found nobody citing this path.

Can anybody help me to get this weird problem solved? Because I need those additional fonts in order to cope with our corporate design.

share|improve this question
    
You shouldn't worry that updmap uses various cfg files. Your problem is that the map-file is not found. Is Users/anouak/Library/texmf/ really a texmf tree of your texlive2012? Do you have an older TeX-installation which could get in the way? –  Ulrike Fischer Sep 4 '12 at 13:40
    
Thank you, Ulrike. Indeed, there is a texmf tree under /Users/anouak/Library/texmf/ and it used to work properly in former installations. That is even acknowleged by kpsewhich as it displays the proper path. There cannot be any older TeX-Installation as the system is setup freshly new. –  Alexander Sep 4 '12 at 15:14
    
It's better to put the font related files in the local tree /usr/local/texlive/texmf-local and run sudo updmap-sys, if you have Administrator privileges. In this way you'll not be concerned with font updates in the main tree. –  egreg Sep 4 '12 at 15:38
    
Thank you egreg, that did the trick, which is quite disappointing as it was working properly in former distributions of TeXLive. Thank you all for all your support. –  Alexander Sep 4 '12 at 22:30
    
Did you get the "resetting $HOME" message when you run it as normal user? That should not happen and would be a bug, please retry and confirm! –  norbert Sep 5 '12 at 8:47
show 2 more comments

closed as too localized by Joseph Wright Oct 6 '12 at 22:22

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.