Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I'm using beamer with textpos to place certain blocks at particular positions (in particular, I use the textblock* environment).

When I attempt to create a handout, the pieces of text within textblock* are moved into (what seems to me) random positions of the page.

Any advice?

Here is a small example:

\documentclass[t, handout]{beamer}

\usepackage[absolute,overlay]{textpos}

\usepackage{pgfpages}
\pgfpagesuselayout{4 on 1}[letterpaper, border shrink = 5mm, landscape]

\mode<presentation>{
  \setbeamercovered{invisible}
}

\usetheme{Madrid}
\usecolortheme{beaver}

\title{Presentation Title}

\author{
  A, B
}

\institute[Institute]{
  The Institute
}

\date{September 5, 2012}

\setbeamertemplate{footline}[frame number]
\setbeamertemplate{navigation symbols}{} 

\begin{document}

\begin{frame}
  \titlepage
\end{frame}

\begin{frame}{Some title}
  Some text
\end{frame}

\begin{frame}[center]{Part A}
  \begin{textblock*}{300pt}(0.1\textwidth, 0.5\textheight)
    \Large
    \centering
    This title should not appear at the first slide!
  \end{textblock*}
\end{frame}

\end{document}
share|improve this question
add comment

2 Answers

Removing the absolute should indeed help. This is noted in passing in the textpos manual, in the section on 'Interactions'

This is because Textpos in absolute mode places its text onto the page at the last moment before the page is shipped out, which will be after Prosper has rotated the page from portrait to landscape format, so that the {textblock} contents end up at the correct position on the portrait page, but the wrong position on the landscape page [...] The same appears to be true with the beamer package.

This will solve the problem as long as the textblock is the first thing on the slide. If it doesn't solve the problem, can you post an example of it failing and I can take a look at that.

share|improve this answer
add comment

Wouldn't just removing the absolute package option solve your problem?

\documentclass[t,handout]{beamer}
\usepackage[overlay]{textpos}
\usepackage{pgfpages}
\pgfpagesuselayout{4 on 1}[letterpaper, border shrink = 5mm, landscape]

\mode<presentation>{
  \setbeamercovered{invisible}
}

\usetheme{Madrid}
\usecolortheme{beaver}

\title{Presentation Title}

\author{
  A, B
}

\institute[Institute]{
  The Institute
}

\date{September 5, 2012}

\setbeamertemplate{footline}[frame number]
\setbeamertemplate{navigation symbols}{} 

\begin{document}

\begin{frame}
  \titlepage
\end{frame}

\begin{frame}{Some title}
  Some text
\end{frame}

\begin{frame}[center]{Part A}
  \begin{textblock*}{300pt}(0.1\textwidth, 0.5\textheight)
    \Large
    \centering
    This title should not appear at the first slide!
  \end{textblock*}
\end{frame}

\end{document}
share|improve this answer
    
It sort of does. The slides in the handout are not identical to the actual handouts, but that is solvable. Thank you! –  user1451817 Sep 6 '12 at 0:37
    
@user1451817 don't forget to upvote Gonzalo's answer using the up arrow. If he has solved the problem, please consider accepting it using the green check mark. This helps keep the site tidy, and also helps to keep Gonzalo at the top of reputation charts :) –  cmhughes Sep 6 '12 at 0:55
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.