Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

Using Kile 2.1 beta 4, TeXlive2010 on Ubuntu 10.04 the call of pdflatex from kile fails with the error "pdflatex-fmt-doesnt-match-pdftex-pool" as it has been reported here.

However, I can compile from the command line without any problems.

Looking at the log-file I found this odd entry

* This is pdfTeX, Version 3.1415926-1.40.10 (**TeX Live 2009/Debian) restricted \write18 enabled.

kpathsea: Running mktexfmt pdflatex.fmt fmtutil: running `pdftex -ini -jobname=pdflatex -progname=pdflatex -translate-file=cp227.tcx *pdflatex.ini' ... This is pdfTeX, Version 3.1415926-1.40.11 (TeX Live 2010) (INITEX) restricted \write18 enabled. (/usr/local/texlive/2010/texmf/web2c/cp227.tcx)

It seems that Kile calls the old texlive 2009 (was never installed on the system). I installed Kile without recommended dependencies to overcome the texlive 2009/2010 problem and just after installation everything worked fine from the command line and using Kile. Deleting texmf-var folder and running fmtutil --all did not solve my problem.

Did something change the configuration after system restart, if yes what and why?

Is there a way to re-configure Kile or do I have to uninstall it, build the dummy package and reinstall Kile in oder to use it with TeXLive2010?

share|improve this question
1  
My impression is, some bits of TL 2009 from the Ubuntu repo got installed. And probably the PATH setting for your command line is different from that used by Kile, which would explain the different behaviour. Could you please show us the output of dpkg -l | grep texlive, which latex, which kpsewhich and kpsewhich latex.fmt? –  mpg Dec 13 '10 at 14:38
    
mpg is right. You have TeXlive 2009 installed as well. Note that Ubuntu's dependencies are separated into recommended and required. You may have installed Kile without its recommended dependencies, but you seem still to have installed its required dependencies. –  frabjous Dec 13 '10 at 14:42
    
It seems that you are rigth as kpsewhich returns me some 2009 files. Calling pdflatex from the command line gives me texlive2010, do I now need to reinstall or is it just a matter of setting the PATH right? –  Martin H Dec 13 '10 at 15:12
1  
Reinstalling TL 2010 won't fix anything. The problem is to get the PATH right. Try starting Kile from the command line to see if it inherits the correct PATH. If you have root access, setting the PATH system-wide in /etc/environment has been reported to work well on Debian-derived systems. Otherwise, search your desktop environment's documentation for the way to set expand the PATH for graphical apps. –  mpg Dec 13 '10 at 15:53
    
Maybe there is a setting somewhere in Kile to set the path. It's a KDE app after all, so it is bound to have lots of settings :) –  Caramdir Dec 13 '10 at 16:08
show 1 more comment

1 Answer 1

up vote 0 down vote accepted

A solution is to build Kile from source. After doing so it works perfectly with TeXLive2010

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.