Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I want to change the behavior of the biblatex-option idemtracker=constrict. In the documentation it is described as follows:

This mode is similar to context with one additional condition: a reference in a footnote will only be considered as unambiguous if the current citation and the previous citation are given in the same footnote or in immediately consecutive footnotes.

Instread of the "same footnote or immediately consecutive footnotes", the idemtracker should only use idem if the citation is within the same footnote.

If the citation comes in the immediately consecutive footnote, the name of the author should be printed. How can I change this behavior?

I am using biblatex-juradiss, which is based on authortitle-dw. I have the autocite=footnote and the \cite command I am using creates either footnotes or within a footnote plain quotes (see Biblatex \autocite in case of would-be nested footnotes).

share|improve this question

1 Answer 1

up vote 6 down vote accepted

This one is probably best solved by patching the internal footnote test used for the constrict tracking mode. To change constrict mode for all trackers you can add the following to your preamble.

\makeatletter
\patchcmd{\blx@ifmpfncheck}{\tw@}{\@ne}{}{}
\makeatother

This example alters constrict mode only for the idem tracker.

\documentclass{article}
\usepackage[style=biblatex-juradiss]{biblatex}

\makeatletter
\let\cbx@ifmpfncheck\blx@ifmpfncheck
\patchcmd{\cbx@ifmpfncheck}{\tw@}{\@ne}{}{}
\let\cbx@ifciteidem@constrict\blx@ifciteidem@constrict
\patchcmd{\cbx@ifciteidem@constrict}{\blx@ifmpfncheck}{\cbx@ifmpfncheck}{}{}
\let\blx@imc@ifciteidem\cbx@ifciteidem@constrict
\makeatother

\addbibresource{biblatex-examples.bib}
\begin{document}
\null\vfill
Filler.\footnote{Filler \cite{knuth:ct:a}. Filler \cite{knuth:ct:b}.}
Filler \autocite{knuth:ct:a}.
Filler \autocite{knuth:ct:a}.
\end{document}

enter image description here

Note that the style here uses the option settings

autocite=footnote,ibidtracker=constrict,idemtracker=constrict
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.