Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I'm working with MikTex2.9 and I couldn't get rid of this warning message:

Package pgf Warning: Your graphic driver pgfsys-dvips.def does not support fadings. This warning is given only once on input line 31.

By trying this example:

\documentclass{article}
\usepackage{tikz}
\usetikzlibrary{shadows}
\begin{document}
\tikzstyle{ball} = [circle,shading=ball, ball color=red!80!white,  drop shadow=black, minimum size=1cm]
\begin{tikzpicture}
\node [style=ball] {blah blah blah};
\end{tikzpicture}
\end{document}

I got a .pdf slightly different from the .dvi file (the shadow is a little lighter) and I was wondering if this problem could be linked with the warning or if it's only a problem of the reader (as reported in: Tikz: Strange color change. ).

Thanks in advance for any suggestions.

share|improve this question
    
@Arianna: why don't you compile to PDF directly? With pdfTeX I don't get that warning. –  Stefan Kottwitz Dec 13 '10 at 18:33
    
By compiling to PDF I don't get the warning, but the shadow is always lighter (it should be black) –  Arianna Angeletti Dec 13 '10 at 18:39
    
@Arianna: ok, "I got a .pdf slightly different from the .dvi file" just read to me like you created the .pdf from the .dvi (dvips/ps2pdf or dvipdfmx), that's why my pdfTeX suggestion. –  Stefan Kottwitz Dec 13 '10 at 18:58
    
from .dvi (with dvips/ps2pdf); from .tex to .pdf with LaTeX => PS => PDF(latex.exe) and with LaTeX => PDF(pdflatex.exe) –  Arianna Angeletti Dec 13 '10 at 19:15
    
I have to try dvipdfmx. Thanks Stefan! –  Arianna Angeletti Dec 13 '10 at 19:17
show 2 more comments

1 Answer

up vote 4 down vote accepted

By default the drop shadow is slightly transparent, which often results in unpredictable behavior when rendering via dvi/postscript.

The default settings for the shadow are opacity=.5, fill=black!50, i.e. medium gray and half transparent.

To turn off the transparency use something like drop shadow={black,opacity=1}.

ball with black shadow

share|improve this answer
    
Thanks Caradmir for your suggestion. Now I get what I expected. –  Arianna Angeletti Dec 15 '10 at 12:37
    
@Arianna. As this answer seems to solve your problem, please 'accept' it by selecting the tick you should see under the voting arrows. –  Joseph Wright Feb 2 '11 at 20:36
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.