Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I'm trying to compile a cv with LaTeX and the europecv class. Compilation fails because a file named uni-global.def is missing.

After a Google search, I found that file should be into the miktex/tex/latex/unicode/data directory. However, that directory contains a data and a contrib folders, both empty. What can I do to solve that error?

Below is the code i wrote.

\documentclass[helvetica,narrow,italian,logo,totpages,booktabs]{europecv}
\usepackage[utf8]{inputenc}
\usepackage[italian]{babel}
\usepackage[T1]{fontenc}
\usepackage{textcomp}
\usepackage{graphicx}
\usepackage{geometry}
\geometry{verbose,a4paper,tmargin=1.27cm,bmargin=2cm,lmargin=1cm,rmargin=1cm}
\usepackage{microtype}

\ecvname{Albert Einistein}
\ecvnationality{Dutch}
\ecvemail{albert.einstein@relativitytheory.de}
\ecvgender{Maschio}

\begin{document}

\begin{europecv}

\ecvpersonalinfo % prints the personal info, defined in the preamble

\end{europecv}

\end{document}
share|improve this question
add comment

1 Answer 1

up vote 6 down vote accepted

It is an error in MiKteX packaging of ucs. I have made a bug report. As workaround you could copy the files of CTAN:macros/latex/contrib/ucs/data/ into the empty data directory (TDS:tex/latex/ucs/data/) and refresh the file name data base afterwards.

Update: The work around does not seem to work for the system distribution tree. But new TDS/texmf trees can be added using MiKTeX Options->Roots->Add. The files can be installed there (the directory structure tex/latex/ucs/ should be kept) and then refresh of the file name data base should work. After MiKTeX has fixed the problem by an update, the additional tree should then be removed.

share|improve this answer
    
I copied the files into the tex/latex/ucs/data directory, then i went on "miktex options" and then onto the "general" tab. There i launched "Refresh FNDB" and the error persisted. Then i tried to reinstall and re-copy the data files but the error remained the same. Any idea? –  Alfatau Sep 8 '12 at 13:38
    
@Alessandro: When you put files in the main tree of miktex you must refresh FNDB in admin mode. –  Ulrike Fischer Sep 8 '12 at 13:49
    
@UlrikeFischer I've an administrator account; my OS is Win7Pro64. How to refresh FNDB in admin mode? Thank you in advance. –  Alfatau Sep 8 '12 at 22:53
    
Docu for initexmf says initexmf --admin --update-fndb. –  Heiko Oberdiek Sep 8 '12 at 22:59
    
BTW: Create a local texmf tree in MiKTeX. –  Speravir Sep 9 '12 at 3:25
show 2 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.