Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

Consider the following MWE :

\documentclass{beamer}

\begin{document}

\begin{frame}

\begin{itemize}[<+->]
\item item
\item item\footnote<.->{footnote}
\item item
\end{itemize}

\end{frame}

\end{document}

The horizontal rule which is displayed between the main text and the footnote is showing on the first slide, although the footnote itself is uncovered only on the second slide.

Is there a way for this rule to be printed only with the footnote and not before?

share|improve this question

2 Answers 2

This rule is not part of the \footnote command but the frame with footnotes. It's drawn with \footnoterule command within \beamer@autobreakframebox in file beamerbaseframesize.sty. When beamer computes frame dimensions it considers if frame has footnotes and draws the rule in this case.

The best solution I can provide is not draw the rule at all. Next code includes a copy of \beamer@autobreakframebox in your file with a commented \footnoterule command. I don't know if this solution will work with other themes (I hope so).

\documentclass{beamer}

\makeatletter
\def\beamer@autobreakframebox{%
  \global\setbox\beamer@splitbox=\box\voidb@x%
  \ifbeamer@autobreak%
    % Ok, frame was overful -> split it!
    \setbox\@tempboxa=\vsplit\beamer@framebox to\beamer@autobreakfactor\textheight%
    \global\setbox\beamer@splitbox=\box\beamer@framebox%
    \@tempdima=\ht\beamer@splitbox%
    \ifdim\@tempdima<\beamer@autobreaklastheight%
      \global\beamer@autobreaklastheight=\@tempdima\relax%
    \else%
      \setbox\@tempboxa=\vbox{\unvbox\@tempboxa\unvbox\beamer@splitbox}%
      \global\setbox\beamer@splitbox=\box\voidb@x%
    \fi%
    \setbox\beamer@framebox=\vbox to\textheight{\unvbox\@tempboxa%
      \vskip\beamer@framebottomskipautobreak%
      \ifvoid\beamer@splitbox%
        \ifvoid\beamer@footins%
        \else%
          \begingroup
            \usebeamercolor*[fg]{footnote}%
%            \footnoterule%
            \unvbox \beamer@footins%
            \global\setbox\beamer@footins=\box\voidb@x%
          \endgroup  
        \fi%
      \fi%
      \beamer@exitcode%
    }%
  \else%
    \setbox\beamer@framebox=\vbox to\textheight{\unvbox\beamer@framebox%
      \vskip\beamer@framebottomskip%
      \ifvoid\beamer@footins%
      \else%
        \begingroup
          \usebeamercolor*[fg]{footnote}%
%         \footnoterule%
          \unvbox \beamer@footins%
          \global\setbox\beamer@footins=\box\voidb@x%
        \endgroup 
      \fi%
      \beamer@exitcode}%
    \global\setbox\beamer@footins=\box\voidb@x%
  \fi%
  }
\makeatother
\begin{document}

\begin{frame}

\begin{itemize}[]
\item<1-> item
\item<2-> {item\footnote<2->{footnote}}
\item<3-> item
\end{itemize}

\end{frame}

\end{document}

enter image description here

share|improve this answer

I know this question is about one year ago but I just encounter the same problem now. The simplest way of disabling the footnoterule will be to redefine the \footnoterule command.

\renewcommand{\footnoterule}{}

However, if you manage to disable the \footnoterule as in Ignasi's answer, you could use

This method only added \footnoterule to your text instead of your footnote. A better workaround is added in the following paragraph

\begin{frame}{frametitle}
My text\footnotemark[1]
...

\uncover<2>{\footnoterule}
\footnotetext[1]<2>{This is my footnote}
\end{frame}

which allows you to show the \footnoterule with your footnote in overlays.

This method only added \footnoterule to your text instead of your footnote. A better workaround is added in the following paragraph

A workaround is to remove the \footnoterule as in Ignasi's answer, and add the \footnoterule in the defbeamertemplate*{footnote} in beamerinnertheme<themename>.sty

% Footnotes

\defbeamertemplate*{footnote}{default}
{
\footnoterule\parindent 1em\noindent%
\raggedright
\hbox to 1.8em{\hfil\insertfootnotemark}\insertfootnotetext\par%
}

This may not be found in beamerinnertheme.sty for all themes but you can always copy this definition from beamerinnerthemedefault.sty and modify it.

share|improve this answer
    
When I work on it, I realise there is some problem with my answer. The uncover<2>{\footnoterule} add the rule in the text instead of the footnote. A workaround has been identified and added to the answer. –  Richard Wong Sep 30 '13 at 9:18

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.