Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

Why i get the error below with this settings?

I use:

TexMakerX 2.2 SVN

TeXLive 2012

Windows

\documentclass{book}

\usepackage[italian]{babel}
\usepackage[babel]{csquotes}
\usepackage{biblatex}
\bibliography{bibliography}


\begin{document}

\cite{bringhurst:elementi}

\printbibliography

\end{document}

bibliography.bib

@book{bringhurst:elementi,
author = {Bringhurst, Robert},
title = {Gli Elementi dello Stile Tipografico},
publisher = {Sylvestre Bonnard},
year = {2001},
location = {Milano}
}

Bibtex command (into the preferences of the editor):

bibtex  %

output

Process started

Process exited with error(s)

.blg file

This is BibTeX, Version 0.99d (TeX Live 2012/W32TeX)
Capacity: max_strings=35307, hash_size=35307, hash_prime=30011
The top-level auxiliary file: dummy.aux
I found no \citation commands---while reading file dummy.aux
I found no \bibdata command---while reading file dummy.aux
I found no \bibstyle command---while reading file dummy.aux
You've used 0 entries,
            0 wiz_defined-function locations,
            83 strings with 484 characters,
and the built_in function-call counts, 0 in all, are:
= -- 0
> -- 0
< -- 0
+ -- 0
- -- 0
* -- 0
:= -- 0
add.period$ -- 0
call.type$ -- 0
change.case$ -- 0
chr.to.int$ -- 0
cite$ -- 0
duplicate$ -- 0
empty$ -- 0
format.name$ -- 0
if$ -- 0
int.to.chr$ -- 0
int.to.str$ -- 0
missing$ -- 0
newline$ -- 0
num.names$ -- 0
pop$ -- 0
preamble$ -- 0
purify$ -- 0
quote$ -- 0
skip$ -- 0
stack$ -- 0
substring$ -- 0
swap$ -- 0
text.length$ -- 0
text.prefix$ -- 0
top$ -- 0
type$ -- 0
warning$ -- 0
while$ -- 0
width$ -- 0
write$ -- 0
(There were 3 error messages)
share|improve this question
1  
Look inside the .blg file that will show the error. –  egreg Sep 10 '12 at 21:09
2  
Add backend=bibtex as package option for package biblatex. –  Kurt Sep 10 '12 at 21:16
1  
biblatex defaults to biber (since version 2.0), so you have to specify explicitly you need bibtex, as @Kurt suggested. –  Count Zero Sep 10 '12 at 21:17
    
@Kurt thanks work ! –  FormlessCloud Sep 10 '12 at 21:19
    
BTW: Well documented question, easy to troubleshoot. Wish we had more of these on SX. :) –  Count Zero Sep 10 '12 at 21:51
show 1 more comment

1 Answer 1

THANKS KURT

\documentclass{book}

\usepackage[italian]{babel}
\usepackage[babel]{csquotes}
\usepackage[backend=bibtex]{biblatex}
\bibliography{bibliography}


\begin{document}

\cite{bringhurst:elementi}

\printbibliography

\end{document}
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.