TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

The bibliography does not appear in the table of contents, have you an idea please?

If I add this:


the bibliography will appear as a chapter in my document!!

share|improve this question
up vote 29 down vote accepted

To get the bibliography to be listed in the ToC as an unnumbered sectional unit (chapter or section), use tocbibind without the numbib option:


Another option would be to use the etoolbox package to patch \thebibliography to use \addcontentsline:


\apptocmd{\thebibliography}{\csname phantomsection\endcsname\addcontentsline{toc}{chapter}{\bibname}}{}{}

share|improve this answer
sorry i want it a chapter in the TOC but without mention in the bibliographie page: Chapter2: Bibliographie – researcher Sep 11 '12 at 19:12
@researcher please see my updated answer. – Gonzalo Medina Sep 11 '12 at 19:57
i have used the second solution because the first one appear the listoffigures and list of table in the TOC – researcher Sep 11 '12 at 20:08
@researcher you can use the notlot, notlof options; see my updated answer. – Gonzalo Medina Sep 11 '12 at 20:10
ok, i have tested the first solution, it works, thank you :) – researcher Sep 11 '12 at 20:14

A very easy way is to include following line before the bibliography starts, at the end of the document.


here is the original post: Insert bibliography into table of content

share|improve this answer
It's problematic - if at the chapter starts at the new page it will show bibliography as starting on previous page then it should. – Maciej Piechotka Jan 12 '13 at 10:42
Yes, i recognized this too. But do you know how it can be changed to the real value even with this function? – XandruCea Jan 12 '13 at 16:21
No. But Gonzalo's method with \usepackage[nottoc,notlot,notlof]{tocbibind} worked. – Maciej Piechotka Jan 12 '13 at 18:33
Ok, than sorry for this, i just recognized it a week later and forgot i just posted this solution here. But thank you for the reminder, otherwise i would be wondering next time again about this . – XandruCea Jan 12 '13 at 20:41
Note that here, Bibliography can be replaced with whatever you like, e.g. References, Works Cited, Orange Monkey List. Of course, it usually makes sense for this text to be the same as the title that appears at the top of your bibliography. – Cerran Mar 5 '14 at 15:28

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.