Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I use pretty cool tikz-uml in my LaTeX with class report. Its works very well!!!

Today, I’m start prepare presentation with beamer. I import all my tikzpictures from report TeX without problems.

But, when I start import UML diagrams (class/sequence diagrams) I have error.

This happens on line \usepackage{tikz-uml} , in the beginning of my beamer file.

Here is error output:

(/usr/share/texmf/tex/latex/lm/omllmm.fd)
(/usr/share/texmf/tex/latex/lm/omslmsy.fd)
(/usr/share/texmf/tex/latex/lm/omxlmex.fd)
(/usr/share/texmf-texlive/tex/latex/amsfonts/umsa.fd)
(/usr/share/texmf-texlive/tex/latex/amsfonts/umsb.fd)
Overfull \hbox (8.46622pt too wide) in paragraph at lines 299--299
 []

 Overfull \hbox (89.75618pt too wide) has occurred while \output is active
  [][]
  [11]
  Overfull \hbox (17.70491pt too wide) in paragraph at lines 325--325
   []
   (/usr/share/texmf/tex/latex/lm/t1lmr.fd)

   LaTeX Font Warning: Font shape `T1/lmss/m/sc' in size <10.95> not available
   (Font)              Font shape `T1/lmr/m/sc' tried instead on input line 325.


   LaTeX Font Warning: Font shape `T1/lmss/m/sc' in size <10> not available
   (Font)              Font shape `T1/lmr/m/sc' tried instead on input line 325.


   Overfull \hbox (89.75618pt too wide) has occurred while \output is active
    [][]
    [12]
    ! No room for a new \count .
    \ch@ck ...\else \errmessage {No room for a new #3}
                                                      \fi
                                                      l.349 \end{frame}

I have verson 0.98 of tikz-uml.sty, downloaded from site.

Here is beginning of my TeX file

\documentclass{beamer}
\usepackage[utf8]{inputenc} %russian support
%\usepackage[francais]{babel} %francais, ussian support
\usepackage[francais]{babel}
\usepackage[T1]{fontenc} %set standart fonts T1. It is Sexy!;Accent codés dans le font

\usepackage{graphicx}
\usepackage {listings}
\usepackage{beamerthemesplit} % biblio items
\usepackage{url} % url


%TIKZ pictures packages
\usepackage{calc}   %chart diagrm
\usepackage{ifthen} %chart diagrm
\usepackage{tikz}   %chart diagrm
\usetikzlibrary{shapes,arrows}   % to draw flow diagramm
\usetikzlibrary{arrows,automata} %to draw fsm

\usepackage{subfig}
%\setlength{\textwidth}{5.1in} % set default alinéa; pour les paresses. Not use it!
\usepackage{times}
\usepackage{float} %subfloat constructions for graphiques 



%listings
\usepackage{color}
\usepackage{xcolor}
\usepackage{listings}


\usepackage{ucs}            %russian support; dependency for lstset
\lstset{ %listing: add accents to 'caption'; default settings for each listings
extendedchars=\true,
inputencoding=utf8x
}
%\DeclareCaptionFont{white}{\color{white}}
%\DeclareCaptionFormat{listing}{\colorbox{gray}{\parbox{\textwidth}{#1#2#3}}}
%\captionsetup[lstlisting]{format=listing,labelfont=white,textfont=white}


%FOR DIAGRAMM CHARTSS
\newcommand{\slice}[4]{
  \pgfmathparse{0.5*#1+0.5*#2}
  \let\midangle\pgfmathresult

  % slice
  \draw[thick,fill=red!50] (0,0) -- (#1:1) arc (#1:#2:1) -- cycle;

  % outer label
  \node[label=\midangle:#4] at (\midangle:1) {};

  % inner label
  \pgfmathparse{min((#2-#1-10)/110*(-0.3),0)}
  \let\temp\pgfmathresult
  \pgfmathparse{max(\temp,-0.5) + 0.8}
  \let\innerpos\pgfmathresult
  \node at (\midangle:\innerpos) {#3};
}

\usepackage{lmodern} %Make text more precise


\usepackage{subfloat}

%%UML, Stata machines
\usepackage{xstring}
\usepackage{pgfopts}
\usepackage{tikz-uml}
...
share|improve this question
    
Maybe if you can remove the irrelevant packages that does not contribute to the problem and make your problem smaller and complete, we can have a look. It is not possible to see why you have exhausted all the counters. I can't check it before I install almost a new TeX distribution. –  percusse Sep 12 '12 at 23:25
2  
Welcome to TeX.SX! A few tips: writing a MWE, and how to mark inline code. –  Count Zero Sep 12 '12 at 23:26

1 Answer 1

up vote 5 down vote accepted

Load the etex package. That should give you access to etex's extended count registers so you have 32768 registers instead of 256.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.