Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I have followed this example and read nomencl package documentation and I can't find a solution. The problem is, that I want to insert nomenclature after TOC, where page numbers are turned off. That is why I get the following error written in .ilg file after makeindex command:

-- Illegal page number .

All the entries are rejected, because it can't include nomenclature without value in nompageref. If I include it after the page numbering starts, than everything works as expected. Here is how the line in .nlo file looks like:

\nomenclatureentry{aCDI@[{CDI}]\begingroup Contexts and Dependency Injection\nomeqref {0}|nompageref}{}

As you can see the nompageref is missing value. Is there a way around to include nomenclature without the need for page number?

share|improve this question
    
Welcome to TeX.SX! May you add a small example of your problem? –  egreg Sep 13 '12 at 8:55

1 Answer 1

up vote 2 down vote accepted

Probably you have turned off the page numbers via

\renewcommand{\thepage}{}

or similar. Then the entries in .nlo are missing the page number and makeindex is not happy with those entries without page number. At least a dummy page number is needed and correct page numbers if option refpage of package nomencl is used. Therefore it is better to turn off the page numbers via the page style instead of turning off redefining \thepage: \pagestyle{empty}, \thispagestyle{empty}, … For more details a MWE would make sense.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.