Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I am facing this strange problem where a figure in one column of a two-column page is blocking the second column. In other words, text is not going there in other column with a figure in the adjacent column. This happens only when the figure happens to be on top of a page. Any clues?

share|improve this question
1  
Are you using figure or figure*? –  Werner Sep 14 '12 at 1:18
    
I am using figure. I am aware of figure* but I need to save space to accomodate more text which is why I am using figure and the issue is that it's not serving its purpose. –  Ketan Sep 14 '12 at 1:25
1  
Without the MWE (requested by Kurt) is hard to provide effective help; I tried to reproduce your problem with some simple test but I wasn't able. Please add to your question the requested MWE. –  Gonzalo Medina Sep 14 '12 at 2:10
    
Thanks for the answers. The problem was solved by one of our collaborators in his edit. I did not pay much attention to it after that. So, am not sure which answer to accept. Community help needed. –  Ketan Feb 1 '13 at 23:26

2 Answers 2

up vote 2 down vote accepted

I've seen this happen when using the dblfloatfix package. I'm not sure why this happens though.

Here's a minimal working example that causes the error for me:

\documentclass[twocolumn,a4paper,10pt]{article}

\usepackage{dblfloatfix}
\usepackage{lipsum}
\usepackage[english]{babel}
\usepackage{times}

\newcommand{\putfig}{
  \begin{figure}[htb]
  \rule{\linewidth}{4cm}
  \caption{Caption}
  \end{figure}
}

\begin{document}
\lipsum[1-7]
\putfig
\lipsum[1]
\lipsum[1-2]
\putfig
\lipsum[1-2]
\putfig
\lipsum[1-5]

\end{document}

Maybe somebody else can elaborate on the cause of this. But please check whether you include that package and whether that might be the culprit.

share|improve this answer

I was having this same problem, but had been using the stfloats package to serve the purpose of dblfloatfix (i.e. elsewhere in the document, I wanted a double column float at the bottom of the page).

I then added dblfloatfix and the text blocking problem went away (but now with compiler warnings).

I then removed stfloats and now the compiler told me I needed to remove the fix2col package.

I removed the fix2col package and everything seemed to work fine.

Perhaps some of these steps will help someone else with this problem.

share|improve this answer
    
Removing strfloats worked for me. Thanks! –  Aaron Massey Mar 23 at 23:21

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.