TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am getting too many errors since I upgraded my computer with the latest version of TeX. For instance, the following piece of code doesn't work any more. Could you help me do a clean install and \ or make the following piece of code work again? I am using the TeXworks editor and I run Ubuntu 12.04 LTS.






Protagoras (\greek{Πρωταγόρας}) says that ``Man is the measure of all things''
(\greek{Ἄνθρωπος μέτρον}), meaning that there is no objective truth. One
opinion can be better than another, but it cannot be \emph{truer}.


EDIT: I attached the .log file.

share|improve this question
I get no error from that input. – egreg Sep 14 '12 at 17:36
That example works fine for me. You should post the .log (and put \listfiles in the preamble of the document). – jon Sep 14 '12 at 17:37
@jon I attached the .log file as you suggested. – eualin Sep 14 '12 at 18:15
Unfortunately the .log file cuts off before the end, and before any error messages are given. – jon Sep 14 '12 at 18:18
using a default 2012 setup I get ! Undefined control sequence. <argument> \textPi on that input. – David Carlisle Sep 14 '12 at 19:19
up vote 2 down vote accepted

I get the error

 ! Undefined control sequence. <argument> \textPi 

searching this site for \textPi lead to a answer that suggested adding


then it appears to work for me.

Note @egreg commented that your unchanged example worked for him. I suspect it should work unchanged. I think that there have been some updates to the Greek support since TL2012 was released so an alternative might be to use the texlive update script to update all relevant packages.

share|improve this answer
It works now. Thank you very much for helping me sort this bug out. – eualin Sep 14 '12 at 19:41

If you use utf8 as option for inputenx, then you can't use directly Greek characters; for this you should add


to your preamble. Otherwise, use utf8x, which however is not compatible with biblatex.

share|improve this answer
I don't really need \usepackage[LGRx,T1]{fontenc}. It works fine with both \usepackage[utf8]{inputenc} and \usepackage[utf8]{inputenx}. But which one to choose? – eualin Sep 15 '12 at 9:49
@eualin With LGRx and utf8 (without textalpha) you're ready for using also biblatex. – egreg Sep 15 '12 at 19:09

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.