Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I have this problem. I use WinEdt 6 to write latex documents and the main language is greek. Up to now i had no problem and i could, when fisrt installing a new version of WinEdt, find a way of having it "read" greek characters properly. Now i'm trying WinEdt 7 and all greek part of the text shows wrong. I tried looking at the relative options but nothing seems to work. I believe the problem is related to the fact that WinEdt 7 has changed the way it supports unicode from version 6. Any tips?

Thank you in advance

share|improve this question
    
I think we'll need some more information on how you work: for example, how are your TeX files encoded, what packages do you use to support Greek, etc. –  Joseph Wright Sep 15 '12 at 13:51
    
Thanks for your reply. First, I have to clarify that the problem appears when trying to open with WInEdt 7 tex files already saved with WinEdt 6. The problem is not with running latex but with the tex (source) file, the greek part of which shows as strange symbols. When running latex(pdflatex to be precise) there is absolutely no problem and the outcome is as expected, but i cannot read the greek part of the tex file in order to edit it if i wish. Still, if needed i can upload both the source file and the style file i have created. –  Andreas Zoupas Sep 17 '12 at 21:37
1  
Can you show us a screenshot of WinEdt with the greek text? Which encodeing do you use in WinEdt (click on tex in the status line to check (or change) the encoding of the editor). –  Kurt Sep 17 '12 at 22:26
    
Well, for some reason since I am a new user I cannot upload any images yet untill my reputation reaches 10. I have taken the screenshots and also clicked on tex in status bar (Thanks for the hint!!) Any ways out? –  Andreas Zoupas Sep 18 '12 at 21:31
    
I am frastrated with the same problem. I cannot solve the problem with the above suggestion. My file comes from winedit 6 and when opened I cannot see greek characters. I tried pdfLatex and the problem remains. It produces pdf with strange symbols. My collegues use winedit 6 and they have no problems with the same file. I used winshell and my problem was solved! I regret that I payed to buy one licence for winedit. I have spend a lot of my time to correct this problem. –  user21820 Nov 6 '12 at 11:25

1 Answer 1

Problem solved and this because of Kurt's suggestion to click on tex in the status line. Even though I use WinEdt for a long time i was not aware of this option, so thanks once more!! By clicking on tex in the status line of WinEdt 7 Document Settings window pops-up. In WinEdt 7 there is a new tab that appears called CP Converter. There I had Document Format: ANSI and the new thing was that i played with: Custom ANSI Code Page, which i set to: 1253 Windows 3.1 Greek. Then i pressed apply and then reload and it worked and greek showed properly!!

Thank you all!!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.