Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

The pdf output generated from by LaTeX is usually not as clear or black as the standard documents would usually be preferred.

The search so far suggests that either the fonts used or the Ghostscript viewer may be a problem (latest is version 9.0 and MikTeX comes with 8.7), but I have not found any information for making the fonts themselves have darker ink so to say.

How can the pdf text be made of clearer print? Please specify the exact packages/fonts/software required.

share|improve this question
9  
Could you provide an example of a LaTeX-produced PDF and a "standard document" to illustrate the difference in clearness/blackness? Your question is hard to answer as it is because if there were a catch-all solution to make things clearer it would be part of the software by default. –  Matthew Leingang Dec 16 '10 at 0:45
1  
What fonts are you using? Computer/Latin Modern do look light on the screen, but look fine when printed, IMHO. –  frabjous Dec 16 '10 at 2:03
    
The problem is more with the printed paper document. It is not as black as is usual in articles, books etc. I will check if the print is better with suggested fonts. Also, when I tried sumatra pdf viewer, the screen output was good but on taking the adobe print of it, the fonts got blurred. Any thoughts on that? –  Anusha Dec 16 '10 at 17:40
2  
It is quite possible that your problem is simply that your actual printing device (the hardware) has less black toner than the offset press used for the books/articles you mention. –  Taco Hoekwater Dec 17 '10 at 11:10
    
@Taco: That does not seem to be the case as the other printouts I take come properly and the boldface print of the latex document is also clear. –  Anusha Dec 17 '10 at 14:02
show 1 more comment

4 Answers

up vote 18 down vote accepted

Standard LaTeX documents without a color package should be black and white, not somehow grayscale. Check it with different viewers.

How can the pdf text be made of more clear print?

If this means, that the text looks fuzzy, ensure that bitmap fonts aren't used. For instance, LaTeX might switch to bitmap fonts, if you use T1 encoding but your font doesn't support it.

Possible Solutions:

  • Get T1 support for the standard Computer modern fonts, i.e. install the cm-super package. There's no change in the document needed.

  • Use a T1 supporting font instead, like the high-quality Latin Modern font, which is similar to the standard fonts: \usepackage{lmodern}

share|improve this answer
3  
Update: Use XeLaTeX or LuaLaTeX, which will get you OpenType fonts. –  Martin Schröder Oct 20 '11 at 21:08
    
The pdf generator should in my opinion print a warning if it cannot use vector fonts, but need to fall back to bitmap fonts. –  Thorbjørn Ravn Andersen May 6 '13 at 9:47
add comment

Lately, I experienced the very same problem: text and graphics produced with pdflatex do not appear totally black. I noticed this on the (laser-printed) test print that I got from the printing company that will print my thesis. (although, when I printed the same document on my own laser printer, the result was perfectly black).

What happens is that the 'black' in the document (as far as I could see, it is stored in the pdf as "0% gray") is converted to a different color scheme, in which it is mapped to something which is not perfectly black. As a result, the printer will use a dithering pattern (black dots with white spots between them) to 'fake' the not-perfectly-blackness. This can be easily seen in two ways:

  • The edges of all texts are ragged. This is not a result of the fonts being bitmapped (they're not), but a result of the fact that, also on the edges, there are white spots which make the edge look ragged.
  • Using \rule{2cm}{2cm} should give a perfectly black rectangle. Because of the large area, you can easily identify a regular pattern, being the dithering pattern of the printer.

Years ago, I experienced the same problem with other PDF's I made (not with Latex) when going to the local copy shop. The problem could be solved by using a different color space in Adobe Acrobat (if I remember correctly, we used Adobe RGB to solve it). Apparently, in that color space, full black (or 0% gray) was mapped onto the most black color available.

As for the printing company, I explained the problem to them and they were able to fix it. I don't know how they did it though, but they were able to do it.

share|improve this answer
3  
Indeed, in my experience this is a RGB/CMYK conversion issue. You might want to ensure that all colors are stored as CMYK in the PDF intended for printout. Use a \usepackage[cmyk]{xcolor} early in the document. Alternatively use \PassOptionsToPackage{cmyk}{xcolor} if you get an option clash because another packages tries to load xcolor without this option. –  Martin Scharrer Oct 18 '11 at 8:15
    
Martin, would that be good enough? If you choose 'black' in CMYK colors (ie, 0% C, 0% M, 0% Y, 100% K) this is not the 'blackest' you can get (by adding some cyan or magenta you get a color called 'rich black', which seems blacker...) So, if you would convert a normal-cmyk-black document to black-and-white in order to print it with a non-color printer (or single-ink press), the color might be mapped to a non-full-black color because there still exist colors that are blacker. Or will it work anyway? Any experience with that? –  Gijs van Oort Oct 18 '11 at 8:33
    
No, I don't have more experience with this. You might check the xcolor manual. I would also say to talk to your printer company if this issue arises. –  Martin Scharrer Oct 18 '11 at 8:44
add comment

I experience this phenomenon, too. But only when using latex -> dvips -> ps2pdf, not with pdflatex.

My quick & dirty workaround is putting \color{black} in my preamble (needs package "color").

Here is a minimal code to reproduce this effect:

\documentclass{minimal}
\usepackage{color}
\begin{document}
    This is a normal text.
    \color{black}
    This is a black text.
\end{document}

I get RGB values of 35 31 32 for the "normal text", but 0 0 0for the "black text".

Honestly, I don't know if that's good practice, it worked for two publications so far.

share|improve this answer
1  
Welcome to TeX.SX. –  Claudio Fiandrino Feb 3 '13 at 18:41
1  
This is the main PostScript produced: TeXDict begin 1 0 bop Black Black 166 83 a Fa(This)28 b(is)f(a)g(normal)g(text.)p 0 TeXcolorgray 37 w(This)h(is)f(a)g(blac)n (k)g(text.)p Black 0 TeXcolorgray eop end –  Martin Schröder Feb 3 '13 at 20:17
    
@ClaudioFiandrino: Thanks :-) –  mpy Feb 3 '13 at 20:54
add comment

Are the fonts you're using too light? Maybe using a thicker font would do what you want.

share|improve this answer
1  
I think for the screen that the charter and bera fonts are the darkest/clearest. Try \usepackage[T1]{fontenc} followed by either \usepackage{bera} or \usepackage[charter]{mathdesign}. –  frabjous Dec 16 '10 at 2:04
    
Can you specify the thicker fonts to be used? Lmodern gives better screen output but the paper printout is still not that good. –  Anusha Dec 19 '10 at 15:45
    
@Anusha: frabjous gave suggestions. –  TH. Dec 19 '10 at 20:27
    
I tried that and asked to confirm if there are any other options. Thanks. –  Anusha Dec 19 '10 at 20:54
2  
@Anusha: You could try any of the fonts in the font catalogue. –  TH. Dec 19 '10 at 22:04
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.