Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I would like to put a & character in a BibTeX publisher tag. Thus far I have tried:

\& {&} {\&} "&"

with the full value enclosed in curly braces and double quotes. No matter what I do I always get a Misplaced alignment tab character &. error. Is there some special way to do this that I'm missing?

Thanks.

share|improve this question
    
I had the same Problem. \& didnt work. I forgot to save the my-bibtex-file.bib after adding the backslash and before compiling everything (in my case 1. PDFLaTeX, 2. BibTex, 3. PDFLaTeX). Hope it helps. –  user14645 May 16 '12 at 10:54
    
I have the same problem but $\&$ works for me –  user33529 Jul 11 '13 at 15:39

5 Answers 5

up vote 42 down vote accepted

I have no problem with

publisher = {Harold \& Maude},

and running pdflatex and bibtex.

share|improve this answer
    
Not sure what my problem was...it seems to be working now though... –  adam Dec 23 '10 at 19:50
1  
After making this change, remember to clear your auxiliary files so that the error doesn't persist! –  Juan A. Navarro Mar 7 at 8:42

When you've typed correctly in the .bib file but still receive errors, go check your .bbl file.

What I usually do is

  1. Delete the whole erroneous line in the .bbl file, save, then close the file.
  2. Make corrections or dummy (temporary) changes in the .bib file, then compile.

This is an example from my .bbl file:

\bibitem{Mohanty2005}

A.~K. Mohanty, M.~Misra, and L.~T.
Drzal.

\newblock {\em {Natural Fibers,
Biopolymers, and Biocomposites}}.

\newblock Taylor {\&} `&` Francis Group,
Florida, 2005.

\newblock ISBN-10: 0-8493-1741-X.

The & is the culprit, not {\&}.

What i do is delete the whole line (newblock Taylor {\&} & Francis Group, Florida, 2005.), save, then close the .bbl file. Make corrections or dummy changes in the .bib file, then compile.


You can simply delete the & in the .bbl file but the next time you make a change in the field that contains that & and compile your .bib file, the error will return.

share|improve this answer
    
Please use back-ticks ` to format inline code and 4-space indention for code blocks. Thanks. –  Martin Scharrer Apr 14 '11 at 7:53

Clear your auxiliary files and then use the \& escape.

EDIT - and by auxiliary files, I mean that many GUI-based editors have a button or menu option for doing this. If you are doing it manually, delete the .bbl file and this should help.

share|improve this answer
5  
Welcome to TeX.SX! You can have a look at our starter guide to familiarize yourself further with our format. –  Paul Gessler Mar 7 at 4:32
2  
It would be nice to add that the files to remove are .bbl and possibly (but probably not necessarily) .aux –  tohecz Mar 7 at 11:25

Typing backslash before the ampersand \& works for me.

share|improve this answer

This worked for me. After getting the same error message I typed a backslash in the .bib file:

publisher = {John Wiley \& Sons},

then I went to the .bbl file and modified the entry from:

\newblock John Wiley & Sons, 2nd edition.

to:

\newblock John Wiley \& Sons, 2nd edition.

and finally I recompiled, in my case: latex->bibtex->latex->latex->dvipdfm->view pdf. It worked :)

share|improve this answer
2  
It is sufficient to change this in the .bib file and then recompile. Your changes in the .bbl file will be overwritten by the bibtex run anyway. –  Andrew Swann Sep 21 '12 at 8:18
    
For me the recompiled latex->bibtex->latex->latex->dvipdfm->view pdf sequence was essential! Without, after escaping the & with \& and saving, it was impossible to recompile my file. –  alex Feb 1 at 21:49

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.