Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I am using a Modified acmtrans document class. It was modified to add a custom journal.

I am having problems using the hyperref package.

My file has the following in the preamble:

\documentclass[mistar,hyperref]{acmtrans2m} 
\usepackage[pdfmark]{hyperref}

When compiling I get the following error:

! Undefined control sequence.
\pdfinfo #1#2->\pdfmark 
    {pdfmark=/DOCINFO,Title=#1,Author=#2}

Can anyone help?

share|improve this question
add comment

1 Answer

up vote 2 down vote accepted

With acmtrans, use LaTeX instead of pdfLaTeX.

Background:

The macro \pdfmark is defined within pdfmark.def which is part of the hyperref package. This will be loaded if you specify the pdfmark option to hyperref (which is an alias for dvips). However it doesn't work with pdfLaTeX: in that case another driver will be forced instead of pdfmark.def. You would get a warning of hyperref:

Package hyperref Warning: Wrong driver `hdvips.def';
(hyperref)                pdfTeX is running in PDF mode.
(hyperref)                Forcing driver `hpdftex.def'.

*hyperref using driver hpdftex*
share|improve this answer
    
I use latexmk to compile the document. Do you know the full command line, to have it use latex instead of pdflatex? –  Tiago Veloso Dec 16 '10 at 16:07
1  
latexmk supports several options. Instead of -pdf, you may use -dvi, -ps, -pdfdvi and/or -pdfps. You may find documentation on phys.psu.edu/~collins/software/latexmk-jcc . –  Stefan Kottwitz Dec 16 '10 at 16:19
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.