TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm using this journal's style files and I can see that the .cls file defines paper size as a4paper in the following line:


However, compiling any document with this class uses a US letter paper, which crops the bottom. I can't even use a4paper as an option. What should I change to get A4 sizing?

If you want an MWE, just try recompiling the gjilguid2e.tex that is present in the zip file. The included PDF file is A4, but upon recompiling, it switches to US letter for me.

share|improve this question
up vote 3 down vote accepted

The class gji does not provide \paperwidth and \paperheight. Also the output driver (pdfTeX, dvips, …) is not notified about the paper dimensions (LaTeX does not do this job). The former can be done manually, the latter can be done by package geometry. Option pass is used to avoid changing the current page layout settings.

\setlength{\paperheight}{297mm}% fixed.
share|improve this answer
Thanks, that solved it. A small typo — 207 should be 297, but that's not essential to the answer :) – user18770 Sep 16 '12 at 7:42
Thanks, that was a test setting that I had forgotten to revert. – Heiko Oberdiek Sep 16 '12 at 7:44

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.